aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 10 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index 17647a9..ab6fe98 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,6 +2,7 @@
2AC_PREREQ(2.61) 2AC_PREREQ(2.61)
3AC_INIT([libextractor], [0.7.0], [bug-libextractor@gnu.org]) 3AC_INIT([libextractor], [0.7.0], [bug-libextractor@gnu.org])
4AC_CONFIG_HEADERS([config.h]) 4AC_CONFIG_HEADERS([config.h])
5AC_CONFIG_MACRO_DIR([m4])
5AH_TOP([#define _GNU_SOURCE 1]) 6AH_TOP([#define _GNU_SOURCE 1])
6AC_CANONICAL_TARGET 7AC_CANONICAL_TARGET
7AC_CANONICAL_HOST 8AC_CANONICAL_HOST
@@ -14,8 +15,6 @@ AC_SUBST(LIB_VERSION_CURRENT)
14AC_SUBST(LIB_VERSION_REVISION) 15AC_SUBST(LIB_VERSION_REVISION)
15AC_SUBST(LIB_VERSION_AGE) 16AC_SUBST(LIB_VERSION_AGE)
16 17
17LT_CONFIG_LTDL_DIR([libltdl])
18AC_CONFIG_AUX_DIR([libltdl/config])
19AM_INIT_AUTOMAKE([silent-rules]) 18AM_INIT_AUTOMAKE([silent-rules])
20 19
21# Checks for programs. 20# Checks for programs.
@@ -30,6 +29,8 @@ AC_PROG_INSTALL
30AC_PROG_LN_S 29AC_PROG_LN_S
31AC_PROG_MAKE_SET 30AC_PROG_MAKE_SET
32AC_CANONICAL_HOST 31AC_CANONICAL_HOST
32AC_LIBLTDL_CONVENIENCE
33AC_PROG_LIBTOOL
33# save LIBS, libtool does a AC_SEARCH_LIBS(dlopen, dl), but plugins 34# save LIBS, libtool does a AC_SEARCH_LIBS(dlopen, dl), but plugins
34# need not have -ldl added 35# need not have -ldl added
35LIBSOLD=$LIBS 36LIBSOLD=$LIBS
@@ -530,7 +531,6 @@ AC_CHECK_LIB(gsf-1, gsf_init, AC_DEFINE(HAVE_GSF_INIT,1,[gsf_init supported]))
530AC_CHECK_PROG([HAVE_ZZUF],[zzuf], 1, 0) 531AC_CHECK_PROG([HAVE_ZZUF],[zzuf], 1, 0)
531AM_CONDITIONAL(HAVE_ZZUF, test 0 != $HAVE_ZZUF) 532AM_CONDITIONAL(HAVE_ZZUF, test 0 != $HAVE_ZZUF)
532 533
533ffmpeg_enabled=0
534AC_MSG_CHECKING([whether to enable the FFmpeg thumbnail extractor]) 534AC_MSG_CHECKING([whether to enable the FFmpeg thumbnail extractor])
535AC_ARG_ENABLE(ffmpeg, 535AC_ARG_ENABLE(ffmpeg,
536 [AC_HELP_STRING([--enable-ffmpeg],[Enable FFmpeg support]) 536 [AC_HELP_STRING([--enable-ffmpeg],[Enable FFmpeg support])
@@ -543,16 +543,16 @@ AC_ARG_ENABLE(ffmpeg,
543 ffmpeg_enabled=1 543 ffmpeg_enabled=1
544 ;; 544 ;;
545 esac], 545 esac],
546 [ AC_MSG_RESULT(no) 546 [ AC_MSG_RESULT(yes)
547 ffmpeg_enabled=0]) 547 ffmpeg_enabled=1])
548AM_CONDITIONAL(HAVE_FFMPEG, test x$ffmpeg_enabled != x0)
549if test x$ffmpeg_enabled = x1 548if test x$ffmpeg_enabled = x1
550then 549then
551 AC_CHECK_HEADERS(libavutil/avutil.h ffmpeg/avutil.h) 550 ffmpeg_enabled=0
552 AC_CHECK_HEADERS(libavformat/avformat.h ffmpeg/avformat.h) 551 AC_CHECK_LIB(swscale, sws_getContext,
553 AC_CHECK_HEADERS(libavcodec/avcodec.h ffmpeg/avcodec.h) 552 ffmpeg_enabled=1)
554 AC_CHECK_HEADERS(libswscale/swscale.h ffmpeg/swscale.h) 553 AC_CHECK_HEADERS([libavutil/avutil.h ffmpeg/avutil.h libavformat/avformat.h ffmpeg/avformat.h libavcodec/avcodec.h ffmpeg/avcodec.h libswscale/swscale.h ffmpeg/swscale.h])
555fi 554fi
555AM_CONDITIONAL(HAVE_FFMPEG, test x$ffmpeg_enabled != x0)
556 556
557 557
558LE_INTLINCL="" 558LE_INTLINCL=""
@@ -658,8 +658,6 @@ fi
658if test "x$ffmpeg_enabled" = "x0" 658if test "x$ffmpeg_enabled" = "x0"
659then 659then
660 AC_MSG_NOTICE([NOTICE: FFmpeg thumbnailer plugin disabled]) 660 AC_MSG_NOTICE([NOTICE: FFmpeg thumbnailer plugin disabled])
661else
662 AC_MSG_NOTICE([NOTICE: FFmpeg thumbnailer plugin enabled (security untested)])
663fi 661fi
664 662
665if test "x$without_gtk" = "xtrue" 663if test "x$without_gtk" = "xtrue"