summaryrefslogtreecommitdiff
path: root/src/plugins/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/Makefile.am')
-rw-r--r--src/plugins/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/src/plugins/Makefile.am b/src/plugins/Makefile.am
index a0e0ae3..8cbe21a 100644
--- a/src/plugins/Makefile.am
+++ b/src/plugins/Makefile.am
@@ -165,6 +165,7 @@ endif
plugin_LTLIBRARIES = \
libextractor_dvi.la \
+ libextractor_elf.la \
libextractor_it.la \
libextractor_man.la \
libextractor_nsf.la \
@@ -200,6 +201,7 @@ endif
check_PROGRAMS = \
test_dvi \
+ test_elf \
test_it \
test_man \
test_nsf \
@@ -283,6 +285,19 @@ test_dvi_SOURCES = \
test_dvi_LDADD = \
$(top_builddir)/src/plugins/libtest.la
+libextractor_elf_la_SOURCES = \
+ elf_extractor.c \
+ pack.c pack.h
+libextractor_elf_la_LDFLAGS = \
+ $(PLUGINFLAGS)
+libextractor_elf_la_LIBADD = \
+ $(XLIB) $(SOCKET_LIBS)
+
+test_elf_SOURCES = \
+ test_elf.c
+test_elf_LDADD = \
+ $(top_builddir)/src/plugins/libtest.la
+
libextractor_exiv2_la_SOURCES = \
exiv2_extractor.cc