aboutsummaryrefslogtreecommitdiff
path: root/src/daemon/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2007-09-09 21:32:12 +0000
committerChristian Grothoff <christian@grothoff.org>2007-09-09 21:32:12 +0000
commitfb36fb2009a35e48be28df422af5a4b42d099cda (patch)
tree103c9372286a794293b36bcc0e18e091bde49f3d /src/daemon/Makefile.am
parent8ce09efc5e3c19d413727e8b80c5f2eff9406b38 (diff)
downloadlibmicrohttpd-fb36fb2009a35e48be28df422af5a4b42d099cda.tar.gz
libmicrohttpd-fb36fb2009a35e48be28df422af5a4b42d099cda.zip
release
Diffstat (limited to 'src/daemon/Makefile.am')
-rw-r--r--src/daemon/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/src/daemon/Makefile.am b/src/daemon/Makefile.am
index 7a4696fc..c9b73287 100644
--- a/src/daemon/Makefile.am
+++ b/src/daemon/Makefile.am
@@ -2,11 +2,17 @@ SUBDIRS = .
2 2
3INCLUDES = -I$(top_srcdir)/src/include 3INCLUDES = -I$(top_srcdir)/src/include
4 4
5if HAVE_GNU_LD
6 retaincommand=-Wl,--retain-symbols-file -Wl,SYMBOLS
7endif
8
9EXTRA_DIST = SYMBOLS
10
5lib_LTLIBRARIES = \ 11lib_LTLIBRARIES = \
6 libmicrohttpd.la 12 libmicrohttpd.la
7 13
8libmicrohttpd_la_LDFLAGS = \ 14libmicrohttpd_la_LDFLAGS = \
9 -export-dynamic -version-info 2:0:0 15 -export-dynamic -version-info 2:0:0 $(retaincommand)
10libmicrohttpd_la_SOURCES = \ 16libmicrohttpd_la_SOURCES = \
11 connection.c connection.h \ 17 connection.c connection.h \
12 daemon.c \ 18 daemon.c \