aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 21 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 49bcd624..4d6e263c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -644,9 +644,30 @@ AM_CONDITIONAL([HAVE_LISTEN_SHUTDOWN], [test "x$mhd_cv_host_shtdwn_trgr_select"
644 644
645# SENDMSG. Should we check for SCM_RIGHTS instead? 645# SENDMSG. Should we check for SCM_RIGHTS instead?
646# https://lists.x.org/archives/xorg-devel/2013-November/038687.html 646# https://lists.x.org/archives/xorg-devel/2013-November/038687.html
647AC_MSG_CHECKING([whether sendmsg is available])
647AC_SEARCH_LIBS(sendmsg, socket, AC_DEFINE([HAVE_SENDMSG],1,[Define if your platform supports sendmsg])) 648AC_SEARCH_LIBS(sendmsg, socket, AC_DEFINE([HAVE_SENDMSG],1,[Define if your platform supports sendmsg]))
649AC_MSG_CHECKING([whether writev is available])
648AC_CHECK_FUNCS([writev]) 650AC_CHECK_FUNCS([writev])
649 651
652# check MSG_MORE defined
653AC_MSG_CHECKING([whether MSG_MORE defined])
654AC_COMPILE_IFELSE([AC_LANG_PROGRAM([
655#include <sys/types.h>
656#include <sys/socket.h>
657
658int main(int argc, char **argv)
659{
660 return MSG_MORE;
661}
662 ])],
663 [
664 AC_MSG_RESULT(yes)
665 AC_DEFINE(HAVE_MSG_MORE, [1], [have MSG_MORE])
666 ],
667 [
668 AC_MSG_RESULT(no)
669 ])
670
650# set GCC options 671# set GCC options
651# use '-fno-strict-aliasing', but only if the compiler 672# use '-fno-strict-aliasing', but only if the compiler
652# and linker can take it 673# and linker can take it