aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 21 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 6f2a7851..c4380511 100644
--- a/configure.ac
+++ b/configure.ac
@@ -279,20 +279,38 @@ AC_ARG_ENABLE([spdy],
279 [disable libmicrospdy]), 279 [disable libmicrospdy]),
280 [enable_spdy=${enableval}], 280 [enable_spdy=${enableval}],
281 [enable_spdy=yes]) 281 [enable_spdy=yes])
282AC_MSG_RESULT($enable_spdy)
283
284if test "$enable_spdy" = "yes"
285then
286 AC_CHECK_HEADERS([openssl/err.h],
287 [AM_CONDITIONAL(HAVE_OPENSSL, true)
288 enable_spdy="yes"],
289 [AM_CONDITIONAL(HAVE_OPENSSL, false)
290 enable_spdy="no"])
291fi
292
282if test "$enable_spdy" = "yes" 293if test "$enable_spdy" = "yes"
283then 294then
284 AC_DEFINE([SPDY_SUPPORT],[1],[include libmicrospdy support]) 295 AC_DEFINE([SPDY_SUPPORT],[1],[include libmicrospdy support])
285else 296else
286 AC_DEFINE([SPDY_SUPPORT],[0],[disable libmicrospdy support]) 297 AC_DEFINE([SPDY_SUPPORT],[0],[disable libmicrospdy support])
287fi 298fi
288AC_MSG_RESULT($enable_spdy)
289AM_CONDITIONAL(ENABLE_SPDY, [test "x$enable_spdy" != "xno"]) 299AM_CONDITIONAL(ENABLE_SPDY, [test "x$enable_spdy" != "xno"])
300AC_MSG_CHECKING(whether we have OpenSSL and thus can support libmicrospdy)
301AC_MSG_RESULT($enable_spdy)
290 302
291spdy_OPENSSL 303spdy_OPENSSL
292# for pkg-config 304# for pkg-config
293SPDY_LIBDEPS="" 305SPDY_LIBDEPS=""
294 306
295 307
308AC_CHECK_HEADERS([spdylay/spdylay.h],
309 [AM_CONDITIONAL(HAVE_SPDYLAY, true)
310 have_spdylay="yes"],
311 [AM_CONDITIONAL(HAVE_SPDYLAY, false)
312 have_spdylay="no"])
313
296AC_SUBST(SPDY_LIB_LDFLAGS) 314AC_SUBST(SPDY_LIB_LDFLAGS)
297# for pkg-config 315# for pkg-config
298AC_SUBST(SPDY_LIBDEPS) 316AC_SUBST(SPDY_LIBDEPS)
@@ -529,6 +547,8 @@ AC_MSG_NOTICE([Configuration Summary:
529 Digest auth.: ${enable_dauth} 547 Digest auth.: ${enable_dauth}
530 Postproc: ${enable_postprocessor} 548 Postproc: ${enable_postprocessor}
531 HTTPS support: ${enable_https} 549 HTTPS support: ${enable_https}
550 libmicrospdy: ${enable_spdy}
551 spdylay (testing): ${have_spdylay}
532]) 552])
533 553
534if test "x$enable_https" = "xyes" 554if test "x$enable_https" = "xyes"