diff options
Diffstat (limited to 'configure.ac')
-rw-r--r-- | configure.ac | 20 |
1 files changed, 8 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac index b12bb253..64631425 100644 --- a/configure.ac +++ b/configure.ac | |||
@@ -3033,28 +3033,26 @@ AM_CONDITIONAL([HAVE_GNUTLS_MTHREAD_BROKEN], [[test "x${mhd_cv_gnutls_mthread_br | |||
3033 | AM_CONDITIONAL([USE_UPGRADE_TLS_TESTS], [[test "x${mhd_cv_gnutls_mthread_broken}" = "xno" || test "x${mhd_cv_gnutls_cli}" = "xyes"]]) | 3033 | AM_CONDITIONAL([USE_UPGRADE_TLS_TESTS], [[test "x${mhd_cv_gnutls_mthread_broken}" = "xno" || test "x${mhd_cv_gnutls_cli}" = "xyes"]]) |
3034 | 3034 | ||
3035 | # optional: HTTP Basic Auth support. Enabled by default | 3035 | # optional: HTTP Basic Auth support. Enabled by default |
3036 | AC_MSG_CHECKING([[whether to support HTTP basic authentication]]) | 3036 | AC_MSG_CHECKING([[whether to support HTTP Basic authentication]]) |
3037 | AC_ARG_ENABLE([bauth], | 3037 | AC_ARG_ENABLE([bauth], |
3038 | AS_HELP_STRING([--disable-bauth], | 3038 | [AS_HELP_STRING([--disable-bauth],[disable HTTP Basic Authentication support])], |
3039 | [disable HTTP basic Auth support]), | ||
3040 | [enable_bauth=${enableval}], | 3039 | [enable_bauth=${enableval}], |
3041 | [enable_bauth=yes]) | 3040 | [enable_bauth=yes]) |
3042 | AS_IF([[test "x$enable_bauth" != "xno"]], | 3041 | AS_IF([[test "x$enable_bauth" != "xno"]], |
3043 | [ enable_bauth=yes | 3042 | [ enable_bauth=yes |
3044 | AC_DEFINE([BAUTH_SUPPORT],[1],[Define to 1 if libmicrohttpd is compiled with basic Auth support.]) ]) | 3043 | AC_DEFINE([BAUTH_SUPPORT],[1],[Define to 1 if libmicrohttpd is compiled with Basic Auth support.]) ]) |
3045 | AM_CONDITIONAL([ENABLE_BAUTH], [test "x$enable_bauth" != "xno"]) | 3044 | AM_CONDITIONAL([ENABLE_BAUTH], [test "x$enable_bauth" != "xno"]) |
3046 | AC_MSG_RESULT([[$enable_bauth]]) | 3045 | AC_MSG_RESULT([[$enable_bauth]]) |
3047 | 3046 | ||
3048 | # optional: HTTP Digest Auth support. Enabled by default | 3047 | # optional: HTTP Digest Auth support. Enabled by default |
3049 | AC_MSG_CHECKING([[whether to support HTTP digest authentication]]) | 3048 | AC_MSG_CHECKING([[whether to support HTTP Digest authentication]]) |
3050 | AC_ARG_ENABLE([dauth], | 3049 | AC_ARG_ENABLE([dauth], |
3051 | AS_HELP_STRING([--disable-dauth], | 3050 | [AS_HELP_STRING([--disable-dauth], [disable HTTP Digest Authentication support])], |
3052 | [disable HTTP basic and digest Auth support]), | ||
3053 | [enable_dauth=${enableval}], | 3051 | [enable_dauth=${enableval}], |
3054 | [enable_dauth=yes]) | 3052 | [enable_dauth=yes]) |
3055 | AS_IF([[test "x$enable_dauth" != "xno"]], | 3053 | AS_IF([[test "x$enable_dauth" != "xno"]], |
3056 | [ enable_dauth=yes | 3054 | [ enable_dauth=yes |
3057 | AC_DEFINE([DAUTH_SUPPORT],[1],[Define to 1 if libmicrohttpd is compiled with digest Auth support.]) ]) | 3055 | AC_DEFINE([DAUTH_SUPPORT],[1],[Define to 1 if libmicrohttpd is compiled with Digest Auth support.]) ]) |
3058 | AM_CONDITIONAL([ENABLE_DAUTH], [test "x$enable_dauth" != "xno"]) | 3056 | AM_CONDITIONAL([ENABLE_DAUTH], [test "x$enable_dauth" != "xno"]) |
3059 | AC_MSG_RESULT([[$enable_dauth]]) | 3057 | AC_MSG_RESULT([[$enable_dauth]]) |
3060 | 3058 | ||
@@ -3063,8 +3061,7 @@ AM_CONDITIONAL([HAVE_ANYAUTH],[test "x$enable_bauth" != "xno" || test "x$enable_ | |||
3063 | # optional: HTTP "Upgrade" support. Enabled by default | 3061 | # optional: HTTP "Upgrade" support. Enabled by default |
3064 | AC_MSG_CHECKING([[whether to support HTTP "Upgrade"]]) | 3062 | AC_MSG_CHECKING([[whether to support HTTP "Upgrade"]]) |
3065 | AC_ARG_ENABLE([[httpupgrade]], | 3063 | AC_ARG_ENABLE([[httpupgrade]], |
3066 | AS_HELP_STRING([[--disable-httpupgrade]], | 3064 | [AS_HELP_STRING([[--disable-httpupgrade]], [disable HTTP "Upgrade" support])], |
3067 | [disable HTTP "Upgrade" support]), | ||
3068 | [AS_VAR_IF([[enable_httpupgrade]],[["no"]],[],[[enable_httpupgrade='yes']])], | 3065 | [AS_VAR_IF([[enable_httpupgrade]],[["no"]],[],[[enable_httpupgrade='yes']])], |
3069 | [[enable_httpupgrade='yes']]) | 3066 | [[enable_httpupgrade='yes']]) |
3070 | AS_VAR_IF([[enable_httpupgrade]],[["yes"]], | 3067 | AS_VAR_IF([[enable_httpupgrade]],[["yes"]], |
@@ -3076,8 +3073,7 @@ AC_MSG_RESULT([[$enable_httpupgrade]]) | |||
3076 | # optional: HTTP cookie parsing support. Enabled by default | 3073 | # optional: HTTP cookie parsing support. Enabled by default |
3077 | AC_MSG_CHECKING([[whether to support HTTP cookie parsing]]) | 3074 | AC_MSG_CHECKING([[whether to support HTTP cookie parsing]]) |
3078 | AC_ARG_ENABLE([[cookie]], | 3075 | AC_ARG_ENABLE([[cookie]], |
3079 | AS_HELP_STRING([[--disable-cookie]], | 3076 | [AS_HELP_STRING([[--disable-cookie]], [disable HTTP cookie parsing support])], |
3080 | [disable HTTP cookie parsing support]), | ||
3081 | [AS_VAR_IF([[enable_cookie]],[["no"]],[],[[enable_cookie='yes']])], | 3077 | [AS_VAR_IF([[enable_cookie]],[["no"]],[],[[enable_cookie='yes']])], |
3082 | [[enable_cookie='yes']]) | 3078 | [[enable_cookie='yes']]) |
3083 | AS_VAR_IF([[enable_cookie]],[["yes"]], | 3079 | AS_VAR_IF([[enable_cookie]],[["yes"]], |