aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 6589b2d7..76903382 100644
--- a/configure.ac
+++ b/configure.ac
@@ -319,7 +319,7 @@ AC_CACHE_CHECK([[for C11 'alignof()' support]], [[mhd_cv_c_alignof]],
319#if (defined (__GNUC__) && __GNUC__ < 4 && __GNUC_MINOR__ < 9 && ! defined(__clang__)) || \ 319#if (defined (__GNUC__) && __GNUC__ < 4 && __GNUC_MINOR__ < 9 && ! defined(__clang__)) || \
320 (defined (__clang__) && __clang_major__ < 8) 320 (defined (__clang__) && __clang_major__ < 8)
321/* GCC before 4.9 and clang before 8.0 have incorrect implementation of 'alignof()' 321/* GCC before 4.9 and clang before 8.0 have incorrect implementation of 'alignof()'
322 which returns preferred alignment instead of minimal required alignment */ 322 which returns preferred alignment instead of minimal required alignment */
323#error Compiler has incorrect implementation of alignof() 323#error Compiler has incorrect implementation of alignof()
324choke me now 324choke me now
325#endif 325#endif
@@ -327,7 +327,7 @@ choke me now
327 int var2[alignof(unsigned int) - 1]; 327 int var2[alignof(unsigned int) - 1];
328 int var3[(alignof(char) > 0) ? 1 : -1]; 328 int var3[(alignof(char) > 0) ? 1 : -1];
329 int var4[(alignof(long) >= 4) ? 1 : -1]; 329 int var4[(alignof(long) >= 4) ? 1 : -1];
330 330
331 /* Mute compiler warnings */ 331 /* Mute compiler warnings */
332 var1[0] = var2[0] = var3[0] = 0; 332 var1[0] = var2[0] = var3[0] = 0;
333 var4[0] = 1; 333 var4[0] = 1;
@@ -344,7 +344,7 @@ choke me now
344 ]], [[ 344 ]], [[
345 /* Should fail if 'alignof()' works */ 345 /* Should fail if 'alignof()' works */
346 int var1[alignof(nonexisting_type) - 1]; 346 int var1[alignof(nonexisting_type) - 1];
347 347
348 /* Mute compiler warnings */ 348 /* Mute compiler warnings */
349 var1[0] = 1; 349 var1[0] = 1;
350 if (var1[0] + 1 == 1) 350 if (var1[0] + 1 == 1)
@@ -1089,7 +1089,7 @@ AC_CACHE_CHECK([size of tv_sec member of struct timeval], [mhd_cv_size_timeval_t
1089static struct timeval test_var; 1089static struct timeval test_var;
1090 ]], 1090 ]],
1091 [ 1091 [
1092 # The size is used only to exclude additional checks/comparision in code 1092 # The size is used only to exclude additional checks/comparison in code
1093 # to avoid compiler warnings. With larger size MHD code will use 1093 # to avoid compiler warnings. With larger size MHD code will use
1094 # additional checks which ensure that value will fit but it may produce 1094 # additional checks which ensure that value will fit but it may produce
1095 # a harmless compiler warning. 1095 # a harmless compiler warning.