aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac41
1 files changed, 0 insertions, 41 deletions
diff --git a/configure.ac b/configure.ac
index 8ca6de41..5c415eb9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3676,47 +3676,6 @@ AC_ARG_WITH([[gnutls]],
3676 3676
3677AS_IF([test "x$with_gnutls" != "xno" && test "x$have_gnutls" != "xyes"], 3677AS_IF([test "x$with_gnutls" != "xno" && test "x$have_gnutls" != "xyes"],
3678 [ 3678 [
3679 AC_CACHE_CHECK([[whether to add pkg-config special search directories]], [mhd_cv_pkgconf_add_dirs],
3680 [
3681 AS_IF([[test "x$host_os" = "xsolaris2.11" && test "x$cross_compiling" = "xno"]],
3682 [
3683 AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
3684char size_chk[7-sizeof(char*)];
3685#if defined(_LP64) || defined(__LP64__) || defined(__x86_64) || defined(__x86_64__)
3686#error This is 64-bit target.
3687choke me now
3688#endif
3689#if defined(__amd64) || defined(__amd64__) || defined(__sparcv9) || defined(__sparc_v9__)
3690#error This is 64-bit target.
3691choke me now
3692#endif
3693 ]], [[]]
3694 )
3695 ],
3696 [
3697 mhd_cv_pkgconf_add_dirs='/usr/lib/pkgconfig/gnutls-3'
3698 ],
3699 [
3700 AS_IF([[test "x$host_cpu" = "xx86_64" || test "x$host_cpu" = "xi386"]],
3701 [[mhd_cv_pkgconf_add_dirs='/usr/lib/amd64/pkgconfig/gnutls-3:/usr/lib/amd64/pkgconfig']],
3702 [[test "x$host_cpu" = "xsparc"]],
3703 [[mhd_cv_pkgconf_add_dirs='/usr/lib/sparkv9/pkgconfig/gnutls-3:/usr/lib/sparkv9/pkgconfig']],
3704 [[mhd_cv_pkgconf_add_dirs='/usr/lib/64/pkgconfig/gnutls-3:/usr/lib/64/pkgconfig']]
3705 )
3706 ]
3707 )
3708 ],
3709 [[ mhd_cv_pkgconf_add_dirs='no' ]]
3710 )
3711 ]
3712 )
3713 AS_IF([[test "x$mhd_cv_pkgconf_add_dirs" != "xno"]],
3714 [
3715 test "x$PKG_CONFIG_PATH" = "x" || PKG_CONFIG_PATH="${PKG_CONFIG_PATH}${PATH_SEPARATOR}"
3716 PKG_CONFIG_PATH="${PKG_CONFIG_PATH}${mhd_cv_pkgconf_add_dirs}"
3717 export PKG_CONFIG_PATH
3718 ]
3719 )
3720 PKG_CHECK_MODULES(GNUTLS, [[gnutls]], 3679 PKG_CHECK_MODULES(GNUTLS, [[gnutls]],
3721 [ 3680 [
3722 have_gnutls_pkgcfg='yes' 3681 have_gnutls_pkgcfg='yes'