aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 18 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 429ba767..c71478e8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -37,6 +37,7 @@ AC_PROG_MAKE_SET
37AC_CANONICAL_HOST 37AC_CANONICAL_HOST
38AM_PROG_LIBTOOL 38AM_PROG_LIBTOOL
39 39
40# set GCC options
40CFLAGS="-Wall -Werror $CFLAGS" 41CFLAGS="-Wall -Werror $CFLAGS"
41# use '-fno-strict-aliasing', but only if the compiler can take it 42# use '-fno-strict-aliasing', but only if the compiler can take it
42if gcc -fno-strict-aliasing -S -o /dev/null -xc /dev/null >/dev/null 2>&1; 43if gcc -fno-strict-aliasing -S -o /dev/null -xc /dev/null >/dev/null 2>&1;
@@ -100,7 +101,15 @@ AC_SUBST(PTHREAD_CPPFLAGS)
100AC_CHECK_MEMBER(pthread_t.p, AC_DEFINE(HAVE_NEW_PTHREAD_T, 1, 101AC_CHECK_MEMBER(pthread_t.p, AC_DEFINE(HAVE_NEW_PTHREAD_T, 1,
101 [Define if you have a post 11/2004 pthread library]), , [#include <pthread.h>]) 102 [Define if you have a post 11/2004 pthread library]), , [#include <pthread.h>])
102 103
103# large file support 104
105# libcurl (required for testing)
106SAVE_LIBS=$LIBS
107LIBCURL_CHECK_CONFIG(,,curl=1,curl=0)
108AM_CONDITIONAL(HAVE_CURL, test x$curl = x1)
109$LIBS=$SAVE_LIBS
110
111
112# large file support (> 4 GB)
104AC_SYS_LARGEFILE 113AC_SYS_LARGEFILE
105AC_FUNC_FSEEKO 114AC_FUNC_FSEEKO
106 115
@@ -113,5 +122,12 @@ AC_SUBST(EXT_LIBS)
113AC_CONFIG_FILES([ 122AC_CONFIG_FILES([
114Makefile 123Makefile
115doc/Makefile 124doc/Makefile
116src/Makefile]) 125src/Makefile
126src/include/Makefile
127src/daemon/Makefile])
117AC_OUTPUT 128AC_OUTPUT
129
130if test "$curl" != 1
131then
132 AC_MSG_NOTICE([WARNING: libcurl not found, testcases cannot be built.])
133fi