diff options
Diffstat (limited to 'configure.ac')
-rw-r--r-- | configure.ac | 20 |
1 files changed, 18 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac index 429ba767..c71478e8 100644 --- a/configure.ac +++ b/configure.ac | |||
@@ -37,6 +37,7 @@ AC_PROG_MAKE_SET | |||
37 | AC_CANONICAL_HOST | 37 | AC_CANONICAL_HOST |
38 | AM_PROG_LIBTOOL | 38 | AM_PROG_LIBTOOL |
39 | 39 | ||
40 | # set GCC options | ||
40 | CFLAGS="-Wall -Werror $CFLAGS" | 41 | CFLAGS="-Wall -Werror $CFLAGS" |
41 | # use '-fno-strict-aliasing', but only if the compiler can take it | 42 | # use '-fno-strict-aliasing', but only if the compiler can take it |
42 | if gcc -fno-strict-aliasing -S -o /dev/null -xc /dev/null >/dev/null 2>&1; | 43 | if gcc -fno-strict-aliasing -S -o /dev/null -xc /dev/null >/dev/null 2>&1; |
@@ -100,7 +101,15 @@ AC_SUBST(PTHREAD_CPPFLAGS) | |||
100 | AC_CHECK_MEMBER(pthread_t.p, AC_DEFINE(HAVE_NEW_PTHREAD_T, 1, | 101 | AC_CHECK_MEMBER(pthread_t.p, AC_DEFINE(HAVE_NEW_PTHREAD_T, 1, |
101 | [Define if you have a post 11/2004 pthread library]), , [#include <pthread.h>]) | 102 | [Define if you have a post 11/2004 pthread library]), , [#include <pthread.h>]) |
102 | 103 | ||
103 | # large file support | 104 | |
105 | # libcurl (required for testing) | ||
106 | SAVE_LIBS=$LIBS | ||
107 | LIBCURL_CHECK_CONFIG(,,curl=1,curl=0) | ||
108 | AM_CONDITIONAL(HAVE_CURL, test x$curl = x1) | ||
109 | $LIBS=$SAVE_LIBS | ||
110 | |||
111 | |||
112 | # large file support (> 4 GB) | ||
104 | AC_SYS_LARGEFILE | 113 | AC_SYS_LARGEFILE |
105 | AC_FUNC_FSEEKO | 114 | AC_FUNC_FSEEKO |
106 | 115 | ||
@@ -113,5 +122,12 @@ AC_SUBST(EXT_LIBS) | |||
113 | AC_CONFIG_FILES([ | 122 | AC_CONFIG_FILES([ |
114 | Makefile | 123 | Makefile |
115 | doc/Makefile | 124 | doc/Makefile |
116 | src/Makefile]) | 125 | src/Makefile |
126 | src/include/Makefile | ||
127 | src/daemon/Makefile]) | ||
117 | AC_OUTPUT | 128 | AC_OUTPUT |
129 | |||
130 | if test "$curl" != 1 | ||
131 | then | ||
132 | AC_MSG_NOTICE([WARNING: libcurl not found, testcases cannot be built.]) | ||
133 | fi | ||