aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 21 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 3d50f571..33b06283 100644
--- a/configure.ac
+++ b/configure.ac
@@ -104,7 +104,6 @@ netbsd*)
104 ;; 104 ;;
105*cygwin*) 105*cygwin*)
106 AC_DEFINE_UNQUOTED(CYGWIN,1,[This is a Cygwin system]) 106 AC_DEFINE_UNQUOTED(CYGWIN,1,[This is a Cygwin system])
107 AC_DEFINE_UNQUOTED(WINDOWS,1,[This is a Windows system])
108 AM_CONDITIONAL(HAVE_GNU_LD, false) 107 AM_CONDITIONAL(HAVE_GNU_LD, false)
109 LDFLAGS="$LDFLAGS -no-undefined" 108 LDFLAGS="$LDFLAGS -no-undefined"
110 ;; 109 ;;
@@ -140,6 +139,27 @@ AC_CHECK_HEADERS([fcntl.h math.h errno.h limits.h stdio.h locale.h sys/stat.h sy
140# Check for optional headers 139# Check for optional headers
141AC_CHECK_HEADERS([sys/select.h sys/types.h sys/time.h sys/msg.h netdb.h netinet/in.h time.h sys/socket.h sys/mman.h arpa/inet.h]) 140AC_CHECK_HEADERS([sys/select.h sys/types.h sys/time.h sys/msg.h netdb.h netinet/in.h time.h sys/socket.h sys/mman.h arpa/inet.h])
142 141
142# IPv6
143AC_MSG_CHECKING(for IPv6)
144AC_TRY_COMPILE([
145#if HAVE_NETINET_IN_H
146#include <netinet/in.h>
147#endif
148#if HAVE_SYS_SOCKET_H
149#include <sys/socket.h>
150#endif
151],[
152int af=AF_INET6;
153int pf=PF_INET6;
154struct sockaddr_in6 sa;
155],[
156have_inet6=yes;
157AC_DEFINE([HAVE_INET6], [1], [Provides IPv6 headers])
158],
159have_inet6=no
160)
161AC_MSG_RESULT($have_inet6)
162
143# libcurl (required for testing) 163# libcurl (required for testing)
144SAVE_LIBS=$LIBS 164SAVE_LIBS=$LIBS
145LIBCURL_CHECK_CONFIG(,,curl=1,curl=0) 165LIBCURL_CHECK_CONFIG(,,curl=1,curl=0)