aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 1 insertions, 18 deletions
diff --git a/configure.ac b/configure.ac
index c779667e..dbfa0bea 100644
--- a/configure.ac
+++ b/configure.ac
@@ -170,23 +170,6 @@ AC_CHECK_HEADERS([sys/sysctl.h netinet/ip_icmp.h netinet/icmp_var.h], [], [],
170 ]] 170 ]]
171) 171)
172 172
173# Checks for gettext.
174m4_ifdef([AM_GNU_GETTEXT], [
175 AS_VAR_SET_IF([enable_nls], [], [[enable_nls=no]])
176 AM_GNU_GETTEXT([external],[need-ngettext])
177 AC_CONFIG_FILES([po/Makefile.in])
178 have_po=yes
179], [
180 have_po=no
181])
182m4_ifdef([AM_GNU_GETTEXT_VERSION], [
183#do not indent here
184AM_GNU_GETTEXT_VERSION([0.20.2])
185])
186AM_CONDITIONAL([HAVE_PO], [ test "$have_po" = yes ])
187
188
189
190 173
191# Adam shostack suggests the following for Windows: 174# Adam shostack suggests the following for Windows:
192# -D_FORTIFY_SOURCE=2 -fstack-protector-all 175# -D_FORTIFY_SOURCE=2 -fstack-protector-all
@@ -3421,6 +3404,7 @@ AM_CONDITIONAL([HAVE_EXPERIMENTAL], [test "x$enable_experimental" = "xyes"])
3421AC_CONFIG_FILES([libmicrohttpd.pc 3404AC_CONFIG_FILES([libmicrohttpd.pc
3422w32/common/microhttpd_dll_res_vc.rc 3405w32/common/microhttpd_dll_res_vc.rc
3423Makefile 3406Makefile
3407po/po-configure.ac
3424contrib/Makefile 3408contrib/Makefile
3425doc/Makefile 3409doc/Makefile
3426doc/doxygen/libmicrohttpd.doxy 3410doc/doxygen/libmicrohttpd.doxy
@@ -3463,7 +3447,6 @@ AC_MSG_NOTICE([GNU libmicrohttpd ${PACKAGE_VERSION} Configuration Summary:
3463 Use debug asserts: ${enable_asserts} 3447 Use debug asserts: ${enable_asserts}
3464 Use sanitizers: ${enabled_sanitizers:=no} 3448 Use sanitizers: ${enabled_sanitizers:=no}
3465 Messages: ${enable_messages} 3449 Messages: ${enable_messages}
3466 Gettext: ${have_po}
3467 Basic auth.: ${enable_bauth} 3450 Basic auth.: ${enable_bauth}
3468 Digest auth.: ${enable_dauth} 3451 Digest auth.: ${enable_dauth}
3469 HTTP "Upgrade": ${enable_httpupgrade} 3452 HTTP "Upgrade": ${enable_httpupgrade}