aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 12 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 263e1f17..1742d16f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -678,8 +678,8 @@ AC_MSG_CHECKING([[for clock_get_time]])
678AC_LINK_IFELSE( 678AC_LINK_IFELSE(
679 [AC_LANG_PROGRAM( 679 [AC_LANG_PROGRAM(
680 [[ 680 [[
681 #include <mach/clock.h> 681#include <mach/clock.h>
682 #include <mach/mach.h> 682#include <mach/mach.h>
683 ]], 683 ]],
684 [[ 684 [[
685 clock_serv_t cs; 685 clock_serv_t cs;
@@ -699,7 +699,16 @@ AC_LINK_IFELSE(
699AC_MSG_CHECKING([[for gethrtime]]) 699AC_MSG_CHECKING([[for gethrtime]])
700AC_LINK_IFELSE( 700AC_LINK_IFELSE(
701 [AC_LANG_PROGRAM( 701 [AC_LANG_PROGRAM(
702 [[#include <sys/time.h>]], [[hrtime_t hrt = gethrtime(); ]]) 702 [[
703#ifdef HAVE_SYS_TIME_H
704/* Solaris define gethrtime() in sys/time.h */
705#include <sys/time.h>
706#endif /* HAVE_SYS_TIME_H */
707#ifdef HAVE_TIME_H
708/* HP-UX define gethrtime() in time.h */
709#include <time.h>
710#endif /* HAVE_TIME_H */
711 ]], [[hrtime_t hrt = gethrtime(); ]])
703 ], 712 ],
704 [ 713 [
705 AC_DEFINE([HAVE_GETHRTIME], [1], [Define to 1 if you have `gethrtime' function.]) 714 AC_DEFINE([HAVE_GETHRTIME], [1], [Define to 1 if you have `gethrtime' function.])