aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 8d5d9e1f..a6af4004 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1438,7 +1438,9 @@ struct timeval test_var;
1438AC_DEFINE_UNQUOTED([SIZEOF_STRUCT_TIMEVAL_TV_SEC], [$mhd_cv_size_timeval_tv_sec], 1438AC_DEFINE_UNQUOTED([SIZEOF_STRUCT_TIMEVAL_TV_SEC], [$mhd_cv_size_timeval_tv_sec],
1439 [The size of `tv_sec' member of `struct timeval', as computed by sizeof]) 1439 [The size of `tv_sec' member of `struct timeval', as computed by sizeof])
1440AC_CHECK_SIZEOF([uint64_t], [], [[#include <stdint.h>]]) 1440AC_CHECK_SIZEOF([uint64_t], [], [[#include <stdint.h>]])
1441AC_CHECK_SIZEOF([int], [], [[#include <stdint.h>]])
1441AC_CHECK_SIZEOF([unsigned int], [], [[#include <stdint.h>]]) 1442AC_CHECK_SIZEOF([unsigned int], [], [[#include <stdint.h>]])
1443AC_CHECK_SIZEOF([unsigned long long], [], [[#include <stdint.h>]])
1442AC_CHECK_SIZEOF([size_t], [], 1444AC_CHECK_SIZEOF([size_t], [],
1443 [[ 1445 [[
1444#ifdef HAVE_STDLIB_H 1446#ifdef HAVE_STDLIB_H
@@ -1450,7 +1452,6 @@ AC_CHECK_SIZEOF([size_t], [],
1450#include <stdio.h> 1452#include <stdio.h>
1451 ]] 1453 ]]
1452) 1454)
1453AC_CHECK_SIZEOF([unsigned long long], [], [[#include <stdint.h>]])
1454 1455
1455AC_CHECK_HEADERS([dlfcn.h],[have_tlsplugin=yes],[have_tlsplugin=no], [AC_INCLUDES_DEFAULT]) 1456AC_CHECK_HEADERS([dlfcn.h],[have_tlsplugin=yes],[have_tlsplugin=no], [AC_INCLUDES_DEFAULT])
1456AM_CONDITIONAL([MHD_HAVE_TLS_PLUGIN], [[test "x$have_tlsplugin" = xyes]]) 1457AM_CONDITIONAL([MHD_HAVE_TLS_PLUGIN], [[test "x$have_tlsplugin" = xyes]])