diff options
Diffstat (limited to 'configure.ac')
-rw-r--r-- | configure.ac | 8 |
1 files changed, 5 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac index 412bd6d1..956fe102 100644 --- a/configure.ac +++ b/configure.ac | |||
@@ -148,12 +148,14 @@ case "$host_os" in | |||
148 | AC_DEFINE_UNQUOTED(OSX,1,[This is an OS X system]) | 148 | AC_DEFINE_UNQUOTED(OSX,1,[This is an OS X system]) |
149 | CFLAGS="-no-cpp-precomp -fno-common $CFLAGS" | 149 | CFLAGS="-no-cpp-precomp -fno-common $CFLAGS" |
150 | mhd_host_os='Darwin' | 150 | mhd_host_os='Darwin' |
151 | shutdown_trig_select='yes' | ||
151 | AC_MSG_RESULT([[$mhd_host_os]]) | 152 | AC_MSG_RESULT([[$mhd_host_os]]) |
152 | ;; | 153 | ;; |
153 | freebsd*) | 154 | freebsd*) |
154 | AC_DEFINE_UNQUOTED(SOMEBSD,1,[This is a BSD system]) | 155 | AC_DEFINE_UNQUOTED(SOMEBSD,1,[This is a BSD system]) |
155 | AC_DEFINE_UNQUOTED(FREEBSD,1,[This is a FreeBSD system]) | 156 | AC_DEFINE_UNQUOTED(FREEBSD,1,[This is a FreeBSD system]) |
156 | mhd_host_os='FreeBSD' | 157 | mhd_host_os='FreeBSD' |
158 | shutdown_trig_select='yes' | ||
157 | AC_MSG_RESULT([[$mhd_host_os]]) | 159 | AC_MSG_RESULT([[$mhd_host_os]]) |
158 | ;; | 160 | ;; |
159 | openbsd*) | 161 | openbsd*) |
@@ -493,7 +495,7 @@ AC_CHECK_DECL([gmtime_s], | |||
493 | extern "C" | 495 | extern "C" |
494 | #endif | 496 | #endif |
495 | struct tm* gmtime_s(const time_t* time, struct tm* result); | 497 | struct tm* gmtime_s(const time_t* time, struct tm* result); |
496 | ]], [[ | 498 | ]], [[ |
497 | struct tm res; | 499 | struct tm res; |
498 | time_t t; | 500 | time_t t; |
499 | gmtime_s (&t, &res); | 501 | gmtime_s (&t, &res); |
@@ -513,7 +515,7 @@ AC_CHECK_DECL([gmtime_s], | |||
513 | extern "C" | 515 | extern "C" |
514 | #endif | 516 | #endif |
515 | errno_t gmtime_s(struct tm* _tm, const time_t* time); | 517 | errno_t gmtime_s(struct tm* _tm, const time_t* time); |
516 | ]], [[ | 518 | ]], [[ |
517 | struct tm res; | 519 | struct tm res; |
518 | time_t t; | 520 | time_t t; |
519 | gmtime_s (&res, &t); | 521 | gmtime_s (&res, &t); |
@@ -526,7 +528,7 @@ AC_CHECK_DECL([gmtime_s], | |||
526 | [AC_MSG_RESULT([[no]]) | 528 | [AC_MSG_RESULT([[no]]) |
527 | ]) | 529 | ]) |
528 | ]) | 530 | ]) |
529 | ], [], | 531 | ], [], |
530 | [[#define __STDC_WANT_LIB_EXT1__ 1 | 532 | [[#define __STDC_WANT_LIB_EXT1__ 1 |
531 | #include<time.h>]]) | 533 | #include<time.h>]]) |
532 | 534 | ||