aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac43
1 files changed, 39 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 2fbb59dd..484090cb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2662,10 +2662,44 @@ AC_MSG_RESULT([[$enable_postprocessor]])
2662 2662
2663 2663
2664# optional: have zzuf, socat? 2664# optional: have zzuf, socat?
2665AC_CHECK_PROG([have_zzuf],[zzuf], [yes], [no]) 2665run_zzuf_tests="no"
2666AC_CHECK_PROG([have_socat],[socat], [yes], [no]) 2666AS_VAR_IF([enable_heavy_tests],["yes"],
2667AM_CONDITIONAL([HAVE_ZZUF], [test "x$have_zzuf" = "xyes"]) 2667 [
2668AM_CONDITIONAL([HAVE_SOCAT], [test "x$have_socat" = "xyes"]) 2668 AS_VAR_IF([enable_curl],["yes"],
2669 [
2670 AC_CHECK_PROG([have_zzuf],[zzuf],[yes],[no])
2671 AS_VAR_IF([have_zzuf],["yes"],
2672 [
2673 AC_CHECK_PROG([have_socat],[socat],[yes],[no])
2674 AS_VAR_IF([have_socat],["yes"],
2675 [
2676 run_zzuf_tests="yes"
2677 run_zzuf_tests_MSG="yes"
2678 ],
2679 [
2680 run_zzuf_tests="no"
2681 run_zzuf_tests_MSG="no, socat tool not found"
2682 ]
2683 )
2684 ],
2685 [
2686 run_zzuf_tests="no"
2687 run_zzuf_tests_MSG="no, zzuf tool not found"
2688 ]
2689 )
2690 ],
2691 [
2692 run_zzuf_tests="no"
2693 run_zzuf_tests_MSG="no, tests with libcurl are not enabled"
2694 ]
2695 )
2696 ],
2697 [
2698 run_zzuf_tests="no"
2699 run_zzuf_tests_MSG="no, heavy tests are not enabled"
2700 ]
2701)
2702AM_CONDITIONAL([RUN_ZZUF_TESTS],[test "x$run_zzuf_tests" = "xyes"])
2669 2703
2670have_gnutls=no 2704have_gnutls=no
2671have_gnutls_sni=no 2705have_gnutls_sni=no
@@ -4285,6 +4319,7 @@ AC_MSG_NOTICE([GNU libmicrohttpd ${PACKAGE_VERSION} Configuration Summary:
4285 Build static lib: ${enable_static} 4319 Build static lib: ${enable_static}
4286 Build shared lib: ${enable_shared} 4320 Build shared lib: ${enable_shared}
4287 Test with libcurl: ${MSG_CURL} 4321 Test with libcurl: ${MSG_CURL}
4322 Fuzzing tests: ${run_zzuf_tests_MSG=no}
4288]) 4323])
4289 4324
4290AS_IF([test "x$enable_https" = "xyes"], 4325AS_IF([test "x$enable_https" = "xyes"],