aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac69
1 files changed, 69 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c9d9f767..7b363d6d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1362,6 +1362,75 @@ int main(void)
1362 ] 1362 ]
1363) 1363)
1364 1364
1365AC_CACHE_CHECK([for usable PAGESIZE macro], [mhd_cv_macro_pagesize_usable],
1366 [
1367 AC_LINK_IFELSE(
1368 [
1369 AC_LANG_PROGRAM(
1370 [[
1371#ifdef HAVE_UNISTD_H
1372#include <unistd.h>
1373#endif
1374#ifdef HAVE_LIMITS_H
1375#include <limits.h>
1376#endif
1377#ifdef HAVE_SYS_PARAM_H
1378#include <sys/param.h>
1379#endif
1380#ifndef PAGESIZE
1381#error No PAGESIZE macro defined
1382choke me now
1383#endif
1384 ]],
1385 [[
1386 long pgsz = PAGESIZE + 0;
1387 if (1 > pgsz) return 1;
1388 ]]
1389 )
1390 ],
1391 [[mhd_cv_macro_pagesize_usable="yes"]], [[mhd_cv_macro_pagesize_usable="no"]]
1392 )
1393 ]
1394)
1395AS_VAR_IF([[mhd_cv_macro_pagesize_usable]], [["yes"]],
1396 [AC_DEFINE([[MHD_USE_PAGESIZE_MACRO]],[[1]],[Define if you have usable PAGESIZE macro])],
1397 [
1398 AC_CACHE_CHECK([for usable PAGE_SIZE macro], [mhd_cv_macro_page_size_usable],
1399 [
1400 AC_LINK_IFELSE(
1401 [
1402 AC_LANG_PROGRAM(
1403 [[
1404#ifdef HAVE_UNISTD_H
1405#include <unistd.h>
1406#endif
1407#ifdef HAVE_LIMITS_H
1408#include <limits.h>
1409#endif
1410#ifdef HAVE_SYS_PARAM_H
1411#include <sys/param.h>
1412#endif
1413#ifndef PAGE_SIZE
1414#error No PAGE_SIZE macro defined
1415choke me now
1416#endif
1417 ]],
1418 [[
1419 long pgsz = PAGE_SIZE + 0;
1420 if (1 > pgsz) return 1;
1421 ]]
1422 )
1423 ],
1424 [[mhd_cv_macro_page_size_usable="yes"]], [[mhd_cv_macro_page_size_usable="no"]]
1425 )
1426 ]
1427 )
1428 AS_VAR_IF([[mhd_cv_macro_page_size_usable]], [["yes"]],
1429 [AC_DEFINE([[MHD_USE_PAGE_SIZE_MACRO]],[[1]],[Define if you have usable PAGE_SIZE macro])]
1430 )
1431 ]
1432)
1433
1365# Check for inter-thread signaling type 1434# Check for inter-thread signaling type
1366AC_ARG_ENABLE([[itc]], 1435AC_ARG_ENABLE([[itc]],
1367 [AS_HELP_STRING([[--enable-itc=TYPE]], [use TYPE of inter-thread communication (pipe, socketpair, eventfd) [auto]])], [], 1436 [AS_HELP_STRING([[--enable-itc=TYPE]], [use TYPE of inter-thread communication (pipe, socketpair, eventfd) [auto]])], [],