diff options
Diffstat (limited to 'configure.ac')
-rw-r--r-- | configure.ac | 30 |
1 files changed, 30 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac index 64631425..b8de0798 100644 --- a/configure.ac +++ b/configure.ac | |||
@@ -3082,6 +3082,34 @@ AS_VAR_IF([[enable_cookie]],[["yes"]], | |||
3082 | AM_CONDITIONAL([ENABLE_COOKIE], [[test "x$enable_cookie" = "xyes"]]) | 3082 | AM_CONDITIONAL([ENABLE_COOKIE], [[test "x$enable_cookie" = "xyes"]]) |
3083 | AC_MSG_RESULT([[$enable_cookie]]) | 3083 | AC_MSG_RESULT([[$enable_cookie]]) |
3084 | 3084 | ||
3085 | # optional: SHA-512/256 support for Digest Auth. Enabled by default. | ||
3086 | AC_ARG_ENABLE([[sha512-256]], | ||
3087 | [AS_HELP_STRING([[--disable-sha512-256]],[disable SHA-512/256 support for Digest Authentication]) | ||
3088 | ], | ||
3089 | [ | ||
3090 | AS_VAR_IF([[enable_sha512_256]],[["yes"]], | ||
3091 | [ | ||
3092 | AS_VAR_IF([enable_dauth],["yes"],[], | ||
3093 | [ | ||
3094 | AC_MSG_WARN([The parameter --enable-sha512-256 is ignored as Digest Authentication is disabled]) | ||
3095 | enable_sha512_256='no' | ||
3096 | ] | ||
3097 | ) | ||
3098 | ],[[enable_sha512_256='no']] | ||
3099 | ) | ||
3100 | ], [[enable_sha512_256="${enable_dauth}"]] | ||
3101 | ) | ||
3102 | AC_MSG_CHECKING([[whether to support SHA-512/256]]) | ||
3103 | AS_VAR_IF([[enable_sha512_256]],[["yes"]], | ||
3104 | [ | ||
3105 | AC_DEFINE([[SHA512_256_SUPPORT]],[[1]], | ||
3106 | [Define to 1 if libmicrohttpd is compiled with SHA-512/256 support.]) | ||
3107 | ] | ||
3108 | ) | ||
3109 | AM_CONDITIONAL([ENABLE_SHA512_256], [[test "x${enable_sha512_256}" = "xyes"]]) | ||
3110 | AC_MSG_RESULT([[${enable_sha512_256}]]) | ||
3111 | |||
3112 | |||
3085 | AC_CACHE_CHECK([[for calloc()]], [[mhd_cv_have_func_calloc]], | 3113 | AC_CACHE_CHECK([[for calloc()]], [[mhd_cv_have_func_calloc]], |
3086 | [ | 3114 | [ |
3087 | AC_LINK_IFELSE([AC_LANG_PROGRAM([[ | 3115 | AC_LINK_IFELSE([AC_LANG_PROGRAM([[ |
@@ -3962,6 +3990,7 @@ AC_MSG_NOTICE([GNU libmicrohttpd ${PACKAGE_VERSION} Configuration Summary: | |||
3962 | Messages: ${enable_messages} | 3990 | Messages: ${enable_messages} |
3963 | Basic auth.: ${enable_bauth} | 3991 | Basic auth.: ${enable_bauth} |
3964 | Digest auth.: ${enable_dauth} | 3992 | Digest auth.: ${enable_dauth} |
3993 | SHA-512/256: ${enable_sha512_256} | ||
3965 | HTTP "Upgrade": ${enable_httpupgrade} | 3994 | HTTP "Upgrade": ${enable_httpupgrade} |
3966 | Cookie parsing: ${enable_cookie} | 3995 | Cookie parsing: ${enable_cookie} |
3967 | Postproc: ${enable_postprocessor} | 3996 | Postproc: ${enable_postprocessor} |
@@ -3982,6 +4011,7 @@ AS_IF([test "x$enable_https" = "xyes"], | |||
3982 | 4011 | ||
3983 | AS_IF([test "x$enable_bauth" != "xyes" || \ | 4012 | AS_IF([test "x$enable_bauth" != "xyes" || \ |
3984 | test "x$enable_dauth" != "xyes" || \ | 4013 | test "x$enable_dauth" != "xyes" || \ |
4014 | test "x${enable_sha512_256}" != "xyes" || \ | ||
3985 | test "x$enable_httpupgrade" != "xyes" || \ | 4015 | test "x$enable_httpupgrade" != "xyes" || \ |
3986 | test "x$enable_cookie" != "xyes" || \ | 4016 | test "x$enable_cookie" != "xyes" || \ |
3987 | test "x$enable_postprocessor" != "xyes"], | 4017 | test "x$enable_postprocessor" != "xyes"], |