diff options
Diffstat (limited to 'configure.ac')
-rw-r--r-- | configure.ac | 72 |
1 files changed, 69 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac index b8de0798..31ae78ec 100644 --- a/configure.ac +++ b/configure.ac | |||
@@ -3082,9 +3082,63 @@ AS_VAR_IF([[enable_cookie]],[["yes"]], | |||
3082 | AM_CONDITIONAL([ENABLE_COOKIE], [[test "x$enable_cookie" = "xyes"]]) | 3082 | AM_CONDITIONAL([ENABLE_COOKIE], [[test "x$enable_cookie" = "xyes"]]) |
3083 | AC_MSG_RESULT([[$enable_cookie]]) | 3083 | AC_MSG_RESULT([[$enable_cookie]]) |
3084 | 3084 | ||
3085 | # optional: MD5 support for Digest Auth. Enabled by default. | ||
3086 | AC_ARG_ENABLE([[md5]], | ||
3087 | [AS_HELP_STRING([[--disable-md5]],[disable MD5 hashing support for Digest Authentication]) | ||
3088 | ], | ||
3089 | [ | ||
3090 | AS_VAR_IF([[enable_md5]],[["yes"]], | ||
3091 | [ | ||
3092 | AS_VAR_IF([enable_dauth],["yes"],[], | ||
3093 | [ | ||
3094 | AC_MSG_WARN([The parameter --enable-md5 is ignored as Digest Authentication is disabled]) | ||
3095 | enable_md5='no' | ||
3096 | ] | ||
3097 | ) | ||
3098 | ],[[enable_md5='no']] | ||
3099 | ) | ||
3100 | ], [[enable_md5="${enable_dauth}"]] | ||
3101 | ) | ||
3102 | AC_MSG_CHECKING([[whether to support MD5]]) | ||
3103 | AS_VAR_IF([[enable_md5]],[["yes"]], | ||
3104 | [ | ||
3105 | AC_DEFINE([[MHD_MD5_SUPPORT]],[[1]], | ||
3106 | [Define to 1 if libmicrohttpd is compiled with MD5 hashing support.]) | ||
3107 | ] | ||
3108 | ) | ||
3109 | AM_CONDITIONAL([ENABLE_MD5], [[test "x${enable_md5}" = "xyes"]]) | ||
3110 | AC_MSG_RESULT([[${enable_md5}]]) | ||
3111 | |||
3112 | # optional: SHA-256 support for Digest Auth. Enabled by default. | ||
3113 | AC_ARG_ENABLE([[sha256]], | ||
3114 | [AS_HELP_STRING([[--disable-sha256]],[disable SHA-256 hashing support for Digest Authentication]) | ||
3115 | ], | ||
3116 | [ | ||
3117 | AS_VAR_IF([[enable_sha256]],[["yes"]], | ||
3118 | [ | ||
3119 | AS_VAR_IF([enable_dauth],["yes"],[], | ||
3120 | [ | ||
3121 | AC_MSG_WARN([The parameter --enable-sha256 is ignored as Digest Authentication is disabled]) | ||
3122 | enable_sha256='no' | ||
3123 | ] | ||
3124 | ) | ||
3125 | ],[[enable_sha256='no']] | ||
3126 | ) | ||
3127 | ], [[enable_sha256="${enable_dauth}"]] | ||
3128 | ) | ||
3129 | AC_MSG_CHECKING([[whether to support SHA-256]]) | ||
3130 | AS_VAR_IF([[enable_sha256]],[["yes"]], | ||
3131 | [ | ||
3132 | AC_DEFINE([[MHD_SHA256_SUPPORT]],[[1]], | ||
3133 | [Define to 1 if libmicrohttpd is compiled with SHA-256 hashing support.]) | ||
3134 | ] | ||
3135 | ) | ||
3136 | AM_CONDITIONAL([ENABLE_SHA256], [[test "x${enable_sha256}" = "xyes"]]) | ||
3137 | AC_MSG_RESULT([[${enable_sha256}]]) | ||
3138 | |||
3085 | # optional: SHA-512/256 support for Digest Auth. Enabled by default. | 3139 | # optional: SHA-512/256 support for Digest Auth. Enabled by default. |
3086 | AC_ARG_ENABLE([[sha512-256]], | 3140 | AC_ARG_ENABLE([[sha512-256]], |
3087 | [AS_HELP_STRING([[--disable-sha512-256]],[disable SHA-512/256 support for Digest Authentication]) | 3141 | [AS_HELP_STRING([[--disable-sha512-256]],[disable SHA-512/256 hashing support for Digest Authentication]) |
3088 | ], | 3142 | ], |
3089 | [ | 3143 | [ |
3090 | AS_VAR_IF([[enable_sha512_256]],[["yes"]], | 3144 | AS_VAR_IF([[enable_sha512_256]],[["yes"]], |
@@ -3102,13 +3156,21 @@ AC_ARG_ENABLE([[sha512-256]], | |||
3102 | AC_MSG_CHECKING([[whether to support SHA-512/256]]) | 3156 | AC_MSG_CHECKING([[whether to support SHA-512/256]]) |
3103 | AS_VAR_IF([[enable_sha512_256]],[["yes"]], | 3157 | AS_VAR_IF([[enable_sha512_256]],[["yes"]], |
3104 | [ | 3158 | [ |
3105 | AC_DEFINE([[SHA512_256_SUPPORT]],[[1]], | 3159 | AC_DEFINE([[MHD_SHA512_256_SUPPORT]],[[1]], |
3106 | [Define to 1 if libmicrohttpd is compiled with SHA-512/256 support.]) | 3160 | [Define to 1 if libmicrohttpd is compiled with SHA-512/256 hashing support.]) |
3107 | ] | 3161 | ] |
3108 | ) | 3162 | ) |
3109 | AM_CONDITIONAL([ENABLE_SHA512_256], [[test "x${enable_sha512_256}" = "xyes"]]) | 3163 | AM_CONDITIONAL([ENABLE_SHA512_256], [[test "x${enable_sha512_256}" = "xyes"]]) |
3110 | AC_MSG_RESULT([[${enable_sha512_256}]]) | 3164 | AC_MSG_RESULT([[${enable_sha512_256}]]) |
3111 | 3165 | ||
3166 | AS_IF([test "x$enable_dauth" != "xno"], | ||
3167 | [ | ||
3168 | AS_IF([test "x${enable_md5}" != "xyes" && test "x${enable_sha256}" != "xyes" && test "x${enable_sha512_256}" != "xyes"], | ||
3169 | [AC_MSG_ERROR([At least one hashing algorithm must be enabled if Digest Auth is enabled])] | ||
3170 | ) | ||
3171 | ] | ||
3172 | ) | ||
3173 | |||
3112 | 3174 | ||
3113 | AC_CACHE_CHECK([[for calloc()]], [[mhd_cv_have_func_calloc]], | 3175 | AC_CACHE_CHECK([[for calloc()]], [[mhd_cv_have_func_calloc]], |
3114 | [ | 3176 | [ |
@@ -3990,6 +4052,8 @@ AC_MSG_NOTICE([GNU libmicrohttpd ${PACKAGE_VERSION} Configuration Summary: | |||
3990 | Messages: ${enable_messages} | 4052 | Messages: ${enable_messages} |
3991 | Basic auth.: ${enable_bauth} | 4053 | Basic auth.: ${enable_bauth} |
3992 | Digest auth.: ${enable_dauth} | 4054 | Digest auth.: ${enable_dauth} |
4055 | MD5: ${enable_md5} | ||
4056 | SHA-256: ${enable_sha256} | ||
3993 | SHA-512/256: ${enable_sha512_256} | 4057 | SHA-512/256: ${enable_sha512_256} |
3994 | HTTP "Upgrade": ${enable_httpupgrade} | 4058 | HTTP "Upgrade": ${enable_httpupgrade} |
3995 | Cookie parsing: ${enable_cookie} | 4059 | Cookie parsing: ${enable_cookie} |
@@ -4011,6 +4075,8 @@ AS_IF([test "x$enable_https" = "xyes"], | |||
4011 | 4075 | ||
4012 | AS_IF([test "x$enable_bauth" != "xyes" || \ | 4076 | AS_IF([test "x$enable_bauth" != "xyes" || \ |
4013 | test "x$enable_dauth" != "xyes" || \ | 4077 | test "x$enable_dauth" != "xyes" || \ |
4078 | test "x${enable_md5}" != "xyes" || \ | ||
4079 | test "x${enable_sha256}" != "xyes" || \ | ||
4014 | test "x${enable_sha512_256}" != "xyes" || \ | 4080 | test "x${enable_sha512_256}" != "xyes" || \ |
4015 | test "x$enable_httpupgrade" != "xyes" || \ | 4081 | test "x$enable_httpupgrade" != "xyes" || \ |
4016 | test "x$enable_cookie" != "xyes" || \ | 4082 | test "x$enable_cookie" != "xyes" || \ |