aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 14 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 49556ebd..5de285d9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2478,8 +2478,20 @@ AC_MSG_RESULT($use_gcov)
2478AM_CONDITIONAL([USE_COVERAGE], [test "x$use_gcov" = "xyes"]) 2478AM_CONDITIONAL([USE_COVERAGE], [test "x$use_gcov" = "xyes"])
2479 2479
2480AX_COUNT_CPUS 2480AX_COUNT_CPUS
2481AS_IF([[test "$CPU_COUNT" -gt "32"]], [[CPU_COUNT="32"]])dnl Limit resource usage 2481AC_MSG_CHECKING([for number of CPU cores to use in tests])
2482AC_SUBST([CPU_COUNT]) 2482AS_VAR_IF([enable_heavy_tests], ["yes"],
2483 [
2484 # Enable usage of many core if heavy tests are enabled
2485 AS_IF([[test "$CPU_COUNT" -gt "32"]], [[CPU_COUNT="32"]])dnl Limit resource usage
2486 ],
2487 [
2488 # Limit usage to just a few cores if heavy tests are not enabled
2489 AS_IF([[test "$CPU_COUNT" -gt "6"]], [[CPU_COUNT="6"]])
2490 AS_IF([[test "$CPU_COUNT" -lt "2"]], [[CPU_COUNT="2"]])
2491 ]
2492)
2493AC_MSG_RESULT(["$CPU_COUNT"])
2494
2483 2495
2484AC_MSG_CHECKING([[whether to enable debug asserts]]) 2496AC_MSG_CHECKING([[whether to enable debug asserts]])
2485AC_ARG_ENABLE([[asserts]], 2497AC_ARG_ENABLE([[asserts]],