aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac31
1 files changed, 18 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index 5e3dc7a5..71557497 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,5 @@
1# This file is part of libmicrohttpd. 1# This file is part of libmicrohttpd.
2# (C) 2006-2017 Christian Grothoff (and other contributing authors) 2# (C) 2006-2018 Christian Grothoff (and other contributing authors)
3# 3#
4# libmicrohttpd is free software; you can redistribute it and/or modify 4# libmicrohttpd is free software; you can redistribute it and/or modify
5# it under the terms of the GNU General Public License as published 5# it under the terms of the GNU General Public License as published
@@ -69,6 +69,22 @@ MHD_SYS_EXT
69LT_INIT([win32-dll]) 69LT_INIT([win32-dll])
70LT_LANG([Windows Resource]) 70LT_LANG([Windows Resource])
71 71
72# Checks for gettext.
73m4_ifdef([AM_GNU_GETTEXT], [
74 AM_GNU_GETTEXT([external],[need-ngettext])
75 AC_CONFIG_FILES([po/Makefile.in])
76 have_po=yes
77], [
78 have_po=no
79])
80m4_ifdef([AM_GNU_GETTEXT_VERSION], [
81#do not indent here
82AM_GNU_GETTEXT_VERSION([0.18.2])
83])
84AM_CONDITIONAL([HAVE_PO], [ test "$have_po" = yes ])
85
86
87
72# Workaround for libgcrypt 88# Workaround for libgcrypt
73AS_IF([[test "x$lt_sysroot" != "x" && test "x$SYSROOT" = "x"]], [[SYSROOT="$lt_sysroot"]]) 89AS_IF([[test "x$lt_sysroot" != "x" && test "x$SYSROOT" = "x"]], [[SYSROOT="$lt_sysroot"]])
74 90
@@ -2019,7 +2035,6 @@ AC_DEFINE_DIR([MHD_PLUGIN_INSTALL_PREFIX], [libdir/libmicrohttpd], [tls plugins]
2019 2035
2020AC_CONFIG_FILES([libmicrohttpd.pc 2036AC_CONFIG_FILES([libmicrohttpd.pc
2021w32/common/microhttpd_dll_res_vc.rc 2037w32/common/microhttpd_dll_res_vc.rc
2022po/configure.acT:po/configure.ac.in
2023Makefile 2038Makefile
2024contrib/Makefile 2039contrib/Makefile
2025doc/Makefile 2040doc/Makefile
@@ -2035,17 +2050,6 @@ src/examples/Makefile
2035src/testcurl/Makefile 2050src/testcurl/Makefile
2036src/testcurl/https/Makefile 2051src/testcurl/https/Makefile
2037src/testzzuf/Makefile]) 2052src/testzzuf/Makefile])
2038AC_CONFIG_COMMANDS([po/configargs.stamp], [
2039 $as_echo "$ac_configure_args" > "$ac_tmp/configargs.stamp" || AC_MSG_ERROR([[cannot create file $ac_tmp/configargs.stamp]])
2040 AS_IF([[cmp -s "po/configargs.stamp" "$ac_tmp/configargs.stamp" >/dev/null 2>&1]],
2041 [AC_MSG_NOTICE([[po/configargs.stamp is unchanged]])],
2042 [
2043 rm -f po/configargs.stamp
2044 mv "$ac_tmp/configargs.stamp" po/configargs.stamp || AC_MSG_ERROR([[cannot create file $ac_tmp/configargs.stamp]])
2045 AC_MSG_NOTICE([[po/configargs.stamp is updated]])
2046 ]
2047 )
2048], [ac_configure_args="$ac_configure_args"])
2049AC_OUTPUT 2053AC_OUTPUT
2050 2054
2051# Finally: summary 2055# Finally: summary
@@ -2069,6 +2073,7 @@ AC_MSG_NOTICE([GNU libmicrohttpd ${PACKAGE_VERSION} Configuration Summary:
2069 Use thread names: ${enable_thread_names} 2073 Use thread names: ${enable_thread_names}
2070 Use debug asserts: ${enable_asserts} 2074 Use debug asserts: ${enable_asserts}
2071 Messages: ${enable_messages} 2075 Messages: ${enable_messages}
2076 Gettext: ${have_po}
2072 Basic auth.: ${enable_bauth} 2077 Basic auth.: ${enable_bauth}
2073 Digest auth.: ${enable_dauth} 2078 Digest auth.: ${enable_dauth}
2074 HTTP "Upgrade": ${enable_httpupgrade} 2079 HTTP "Upgrade": ${enable_httpupgrade}