aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac36
1 files changed, 0 insertions, 36 deletions
diff --git a/configure.ac b/configure.ac
deleted file mode 100644
index 39fed6af..00000000
--- a/configure.ac
+++ /dev/null
@@ -1,36 +0,0 @@
1dnl Process this file with autoconf to produce a configure script.
2AC_INIT([libwebserver],[0.5.3-GNUnet],[bug-gnunet@gnu.org])
3AM_INIT_AUTOMAKE([libwebserver], [0.5.3-GNUnet])
4AC_CONFIG_HEADER([config.h])
5
6AC_PROG_CC
7AC_PROG_MAKE_SET
8AC_PROG_INSTALL
9AC_DISABLE_STATIC
10AC_PROG_LIBTOOL
11
12AC_HEADER_STDC
13AC_CHECK_HEADERS([arpa/inet.h fcntl.h limits.h netinet/in.h stddef.h stdlib.h string.h sys/socket.h sys/time.h unistd.h])
14
15# Checks for typedefs, structures, and compiler characteristics.
16AC_C_CONST
17AC_TYPE_SIZE_T
18AC_HEADER_TIME
19AC_STRUCT_TM
20
21# Checks for library functions.
22AC_FUNC_MEMCMP
23AC_TYPE_SIGNAL
24AC_FUNC_STRFTIME
25AC_FUNC_VPRINTF
26AC_CHECK_FUNCS([inet_ntoa memset select socket strchr strerror strncasecmp strstr strtol])
27
28AC_SUBST(INCLUDE)
29AC_SUBST(LIBDIR)
30AC_SUBST(LIBS)
31
32AC_CONFIG_FILES([Makefile
33src/Makefile
34include/Makefile
35])
36AC_OUTPUT