diff options
Diffstat (limited to 'configure.ac')
-rw-r--r-- | configure.ac | 46 |
1 files changed, 43 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac index 6b4a0378..44ac85c3 100644 --- a/configure.ac +++ b/configure.ac | |||
@@ -2643,10 +2643,48 @@ MHD_CHECK_FUNC([[sysctl]], [[ | |||
2643 | #ifdef HAVE_SYS_SYSCTL_H | 2643 | #ifdef HAVE_SYS_SYSCTL_H |
2644 | #include <sys/sysctl.h> | 2644 | #include <sys/sysctl.h> |
2645 | #endif | 2645 | #endif |
2646 | #ifdef HAVE_STDDEF_H | 2646 | #if defined(HAVE_STDDEF_H) |
2647 | #include <stddef.h> | 2647 | #include <stddef.h> |
2648 | #elif defined(HAVE_STDLIB_H) | ||
2649 | #include <stdlib.h> | ||
2648 | #endif | 2650 | #endif |
2649 | ]], [[int mib[2] = {CTL_KERN, KERN_MAXPROC}; i][f (sysctl(mib, 2, NULL, NULL, NULL, 0)) return 1;]] | 2651 | ]], [[ |
2652 | int mib[2] = {0, 0}; /* Avoid any platform-specific values */ | ||
2653 | i][f (sysctl(mib, 2, NULL, NULL, NULL, 0)) return 1; | ||
2654 | ]], | ||
2655 | [ | ||
2656 | AC_CHECK_DECLS([CTL_NET,PF_INET,IPPROTO_ICMP,ICMPCTL_ICMPLIM],[],[], | ||
2657 | [[ | ||
2658 | #ifdef HAVE_SYS_TYPES_H | ||
2659 | #include <sys/types.h> | ||
2660 | #endif /* HAVE_SYS_TYPES_H */ | ||
2661 | #ifdef HAVE_SYS_SYSCTL_H | ||
2662 | #include <sys/sysctl.h> | ||
2663 | #endif /* HAVE_SYS_SYSCTL_H */ | ||
2664 | #ifdef HAVE_SYS_SYSCTL_H | ||
2665 | #include <sys/sysctl.h> | ||
2666 | #endif /* HAVE_SYS_SYSCTL_H */ | ||
2667 | #ifdef HAVE_SYS_SOCKET_H | ||
2668 | #include <sys/socket.h> | ||
2669 | #endif /* HAVE_SYS_SOCKET_H */ | ||
2670 | #ifdef HAVE_NETINET_IN_SYSTM_H | ||
2671 | #include <netinet/in_systm.h> | ||
2672 | #endif /* HAVE_NETINET_IN_SYSTM_H */ | ||
2673 | #ifdef HAVE_NETINET_IN_H | ||
2674 | #include <netinet/in.h> | ||
2675 | #endif /* HAVE_NETINET_IN_H */ | ||
2676 | #ifdef HAVE_NETINET_IP_H | ||
2677 | #include <netinet/ip.h> | ||
2678 | #endif /* HAVE_NETINET_IP_H */ | ||
2679 | #ifdef HAVE_NETINET_IP_ICMP_H | ||
2680 | #include <netinet/ip_icmp.h> | ||
2681 | #endif /* HAVE_NETINET_IP_ICMP_H */ | ||
2682 | #ifdef HAVE_NETINET_ICMP_VAR_H | ||
2683 | #include <netinet/icmp_var.h> | ||
2684 | #endif /* HAVE_NETINET_ICMP_VAR_H */ | ||
2685 | ]] | ||
2686 | ) | ||
2687 | ] | ||
2650 | ) | 2688 | ) |
2651 | 2689 | ||
2652 | MHD_CHECK_FUNC([[sysctlbyname]], [[ | 2690 | MHD_CHECK_FUNC([[sysctlbyname]], [[ |
@@ -2656,8 +2694,10 @@ MHD_CHECK_FUNC([[sysctlbyname]], [[ | |||
2656 | #ifdef HAVE_SYS_SYSCTL_H | 2694 | #ifdef HAVE_SYS_SYSCTL_H |
2657 | #include <sys/sysctl.h> | 2695 | #include <sys/sysctl.h> |
2658 | #endif | 2696 | #endif |
2659 | #ifdef HAVE_STDDEF_H | 2697 | #if defined(HAVE_STDDEF_H) |
2660 | #include <stddef.h> | 2698 | #include <stddef.h> |
2699 | #elif defined(HAVE_STDLIB_H) | ||
2700 | #include <stdlib.h> | ||
2661 | #endif | 2701 | #endif |
2662 | ]], [[sysctlbyname("test", NULL, NULL, NULL, 0);]] | 2702 | ]], [[sysctlbyname("test", NULL, NULL, NULL, 0);]] |
2663 | ) | 2703 | ) |