aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ec27649d..3ee40378 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1073,6 +1073,9 @@ AC_CHECK_HEADER([[search.h]],
1073AM_CONDITIONAL([MHD_HAVE_TSEARCH], [[test "x$ac_cv_header_search_h" = xyes && test "x$HAVE_TSEARCH" = "x1" && test "x$REPLACE_TSEARCH" != "x1"]]) 1073AM_CONDITIONAL([MHD_HAVE_TSEARCH], [[test "x$ac_cv_header_search_h" = xyes && test "x$HAVE_TSEARCH" = "x1" && test "x$REPLACE_TSEARCH" != "x1"]])
1074 1074
1075# Check for types sizes 1075# Check for types sizes
1076# Types sizes are used as an indirect indication of maximum allowed values for types
1077# which is used to exclude by preprocessor some compiler checks for values clips
1078# Assuming no staffing or uniform staffing for integer types
1076AC_CACHE_CHECK([size of tv_sec member of struct timeval], [mhd_cv_size_timeval_tv_sec], 1079AC_CACHE_CHECK([size of tv_sec member of struct timeval], [mhd_cv_size_timeval_tv_sec],
1077 [ 1080 [
1078 AC_COMPUTE_INT([mhd_cv_size_timeval_tv_sec], [((long int)sizeof(test_var.tv_sec))], 1081 AC_COMPUTE_INT([mhd_cv_size_timeval_tv_sec], [((long int)sizeof(test_var.tv_sec))],
@@ -1103,6 +1106,17 @@ AC_DEFINE_UNQUOTED([SIZEOF_STRUCT_TIMEVAL_TV_SEC], [$mhd_cv_size_timeval_tv_sec]
1103 [The size of `tv_sec' member of `struct timeval', as computed by sizeof]) 1106 [The size of `tv_sec' member of `struct timeval', as computed by sizeof])
1104AC_CHECK_SIZEOF([uint64_t], [], [[#include <stdint.h>]]) 1107AC_CHECK_SIZEOF([uint64_t], [], [[#include <stdint.h>]])
1105AC_CHECK_SIZEOF([unsigned int], [], [[#include <stdint.h>]]) 1108AC_CHECK_SIZEOF([unsigned int], [], [[#include <stdint.h>]])
1109AC_CHECK_SIZEOF([size_t], [],
1110 [[
1111#ifdef HAVE_STDLIB_H
1112#include <stdlib.h>
1113#endif /* HAVE_STDLIB_H */
1114#ifdef HAVE_STDDEF_H
1115#include <stddef.h>
1116#endif /* HAVE_STDDEF_H */
1117#include <stdio.h>
1118 ]]
1119)
1106 1120
1107AC_CHECK_HEADERS([dlfcn.h],[have_tlsplugin=yes],[have_tlsplugin=no], [AC_INCLUDES_DEFAULT]) 1121AC_CHECK_HEADERS([dlfcn.h],[have_tlsplugin=yes],[have_tlsplugin=no], [AC_INCLUDES_DEFAULT])
1108AM_CONDITIONAL([MHD_HAVE_TLS_PLUGIN], [[test "x$have_tlsplugin" = xyes]]) 1122AM_CONDITIONAL([MHD_HAVE_TLS_PLUGIN], [[test "x$have_tlsplugin" = xyes]])