aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac38
1 files changed, 38 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8b7489c3..5d9ac157 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1745,6 +1745,12 @@ AC_ARG_ENABLE([[examples]],
1745test "x$enable_examples" = "xno" || enable_examples=yes 1745test "x$enable_examples" = "xno" || enable_examples=yes
1746AM_CONDITIONAL([BUILD_EXAMPLES], [test "x$enable_examples" = "xyes"]) 1746AM_CONDITIONAL([BUILD_EXAMPLES], [test "x$enable_examples" = "xyes"])
1747 1747
1748AC_ARG_ENABLE([[tools]],
1749 [AS_HELP_STRING([[--disable-tools]], [do not build testing and demo tools])], ,
1750 [enable_tools=yes])
1751test "x$enable_tools" = "xyes" || enable_tools=no
1752AM_CONDITIONAL([BUILD_TOOLS], [test "x$enable_tools" = "xyes"])
1753
1748AC_ARG_ENABLE([[heavy-tests]], 1754AC_ARG_ENABLE([[heavy-tests]],
1749 [AS_HELP_STRING([[--enable-heavy-tests[=SCOPE]]], [use SCOPE of heavy tests in test-suite. WARNING:] 1755 [AS_HELP_STRING([[--enable-heavy-tests[=SCOPE]]], [use SCOPE of heavy tests in test-suite. WARNING:]
1750 [a dedicated host with minimal number of background processes and no network] 1756 [a dedicated host with minimal number of background processes and no network]
@@ -3895,6 +3901,34 @@ AS_VAR_IF([mhd_cv_ipv6_for_testing],["yes"],
3895 [AC_DEFINE([[USE_IPV6_TESTING]], [[1]], [Define to 1 if your kernel supports IPv6 and IPv6 is enabled and useful for testing.])] 3901 [AC_DEFINE([[USE_IPV6_TESTING]], [[1]], [Define to 1 if your kernel supports IPv6 and IPv6 is enabled and useful for testing.])]
3896) 3902)
3897 3903
3904AS_VAR_IF([enable_tools],["yes"],
3905 [
3906 MHD_CHECK_FUNC([pclose],[[#include <stdio.h>]],
3907 [[
3908 i][f (0 == pclose(NULL)) return 2;
3909 ]],
3910 [
3911 MHD_CHECK_FUNC([popen],[[#include <stdio.h>]],
3912 [[
3913 FILE *cmd_out = popen ("cat conftest.c", "r");
3914 i][f (NULL == cmd_out) return 2;
3915 i][f (0 != pclose(cmd_out)) return 3;
3916 ]]
3917 )
3918 ]
3919 )
3920 MATH_LIB=''
3921 MHD_FIND_LIB([sqrt],[#include <math.h>],
3922 [[
3923 double res = sqrt ((double) 4);
3924 i][f (((double) 2) != res) return 2;
3925 ]],[m],
3926 [AC_DEFINE([[HAVE_SQRT_FUNC]],[[1]],[Define to 1 i][f 'sqrt()' function is available.])
3927 ],[],[MATH_LIB]
3928 )
3929 AC_SUBST([MATH_LIB])
3930 ]
3931)
3898 3932
3899# Check for fork() and waitpid(). They are used for tests. 3933# Check for fork() and waitpid(). They are used for tests.
3900AC_MSG_CHECKING([[for fork()]]) 3934AC_MSG_CHECKING([[for fork()]])
@@ -3960,6 +3994,8 @@ AC_MSG_RESULT($use_gcov)
3960AM_CONDITIONAL([USE_COVERAGE], [test "x$use_gcov" = "xyes"]) 3994AM_CONDITIONAL([USE_COVERAGE], [test "x$use_gcov" = "xyes"])
3961 3995
3962AX_COUNT_CPUS 3996AX_COUNT_CPUS
3997AC_SUBST([MHD_REAL_CPU_COUNT],[${CPU_COUNT}])
3998AM_SUBST_NOTMAKE([MHD_REAL_CPU_COUNT])
3963AC_MSG_CHECKING([for number of CPU cores to use in tests]) 3999AC_MSG_CHECKING([for number of CPU cores to use in tests])
3964AS_VAR_IF([use_heavy_tests], ["yes"], 4000AS_VAR_IF([use_heavy_tests], ["yes"],
3965 [ 4001 [
@@ -5002,6 +5038,7 @@ src/lib/Makefile
5002src/microhttpd/Makefile 5038src/microhttpd/Makefile
5003src/microhttpd_ws/Makefile 5039src/microhttpd_ws/Makefile
5004src/examples/Makefile 5040src/examples/Makefile
5041src/tools/Makefile
5005src/testcurl/Makefile 5042src/testcurl/Makefile
5006src/testcurl/https/Makefile 5043src/testcurl/https/Makefile
5007src/testzzuf/Makefile]) 5044src/testzzuf/Makefile])
@@ -5077,6 +5114,7 @@ AC_MSG_NOTICE([GNU libmicrohttpd ${PACKAGE_VERSION} Configuration Summary:
5077 Use sanitizers: ${enabled_sanitizers:=no} 5114 Use sanitizers: ${enabled_sanitizers:=no}
5078 Build docs: ${enable_doc} 5115 Build docs: ${enable_doc}
5079 Build examples: ${enable_examples} 5116 Build examples: ${enable_examples}
5117 Build tools: ${enable_examples}
5080 Build static lib: ${enable_static} 5118 Build static lib: ${enable_static}
5081 Build shared lib: ${enable_shared} 5119 Build shared lib: ${enable_shared}
5082 Test with libcurl: ${MSG_CURL} 5120 Test with libcurl: ${MSG_CURL}