diff options
Diffstat (limited to 'configure.ac')
-rw-r--r-- | configure.ac | 39 |
1 files changed, 0 insertions, 39 deletions
diff --git a/configure.ac b/configure.ac index 97a5263a..d57e08b5 100644 --- a/configure.ac +++ b/configure.ac | |||
@@ -292,49 +292,13 @@ fi | |||
292 | AM_CONDITIONAL(MHD_DEBUG_TLS, test "$enable_client_side" != "no") | 292 | AM_CONDITIONAL(MHD_DEBUG_TLS, test "$enable_client_side" != "no") |
293 | 293 | ||
294 | 294 | ||
295 | # optional: TLS support. Included by default | ||
296 | AC_MSG_CHECKING(--enable-TLS argument) | ||
297 | AC_ARG_ENABLE([TLS], | ||
298 | [AS_HELP_STRING([--enable-TLS], | ||
299 | [enable TLS support (default is yes)])], | ||
300 | [enable_TLS=$enableval], | ||
301 | [enable_TLS="yes"]) | ||
302 | AC_MSG_RESULT($enable_TLS) | ||
303 | |||
304 | |||
305 | # optional: SSLv3 support. Exclude by default | ||
306 | AC_MSG_CHECKING(--enable-SSL argument) | ||
307 | AC_ARG_ENABLE([SSL], | ||
308 | [AS_HELP_STRING([--enable-SSL], | ||
309 | [enable SSLv3 support (default is no)])], | ||
310 | [enable_SSL=$enableval], | ||
311 | [enable_SSL="no"]) | ||
312 | AC_MSG_RESULT($enable_SSL) | ||
313 | |||
314 | |||
315 | # optional: x509 certificate support. Include by default | ||
316 | AC_MSG_CHECKING(--enable-x509 argument) | ||
317 | AC_ARG_ENABLE([x509], | ||
318 | [AS_HELP_STRING([--enable-x509], | ||
319 | [enable x509 support (default is yes)])], | ||
320 | [enable_x509=$enableval], | ||
321 | [enable_x509="yes"]) | ||
322 | AC_MSG_RESULT($enable_x509) | ||
323 | |||
324 | # test for libz (optional feature for HTTPS) | 295 | # test for libz (optional feature for HTTPS) |
325 | zlib=1 | 296 | zlib=1 |
326 | AC_CHECK_LIB(z, compress,,zlib=0) | 297 | AC_CHECK_LIB(z, compress,,zlib=0) |
327 | AM_CONDITIONAL(HAVE_LIBZ, test x$zlib = x1) | 298 | AM_CONDITIONAL(HAVE_LIBZ, test x$zlib = x1) |
328 | 299 | ||
329 | # Symbols required by GNU_TLS | 300 | # Symbols required by GNU_TLS |
330 | AC_DEFINE([ENABLE_MINITASN1],[1],[Include minitasn1 support]) | ||
331 | AC_DEFINE([GNULIB_GC_HMAC_SHA1],[1],[GNULIB_GC_HMAC_SHA1]) | ||
332 | AC_DEFINE([GNULIB_GC_RANDOM],[1],[GNULIB_GC_RANDOM]) | 301 | AC_DEFINE([GNULIB_GC_RANDOM],[1],[GNULIB_GC_RANDOM]) |
333 | AC_DEFINE([ENABLE_PKI],[0],[Include PKI support]) | ||
334 | # gnutls debug support | ||
335 | AC_DEFINE([DEBUG],[1],[Include gnutls debug message support]) | ||
336 | AC_DEFINE([C99_MACROS],[1],[Include gnutls debug message support]) | ||
337 | |||
338 | 302 | ||
339 | 303 | ||
340 | # gcov compilation | 304 | # gcov compilation |
@@ -403,9 +367,6 @@ AC_MSG_NOTICE([Configuration Summary: | |||
403 | if test "$enable_HTTPS" = "yes" | 367 | if test "$enable_HTTPS" = "yes" |
404 | then | 368 | then |
405 | AC_MSG_NOTICE([HTTPS subsystem configuration: | 369 | AC_MSG_NOTICE([HTTPS subsystem configuration: |
406 | TLS support: ${enable_TLS} | ||
407 | SSLv3 support: ${enable_SSL} | ||
408 | x509 support: ${enable_x509} | ||
409 | Client code dep.: ${MSG_CLIENT_SIDE} | 370 | Client code dep.: ${MSG_CLIENT_SIDE} |
410 | ]) | 371 | ]) |
411 | if test "$zlib" != 1 | 372 | if test "$zlib" != 1 |