aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac33
1 files changed, 21 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index 4fd23141..3d50f571 100644
--- a/configure.ac
+++ b/configure.ac
@@ -27,13 +27,22 @@ AM_CONFIG_HEADER([MHD_config.h])
27 27
28AH_TOP([#define _GNU_SOURCE 1]) 28AH_TOP([#define _GNU_SOURCE 1])
29 29
30if test `uname -s` == "OS/S390" 30if test `uname -s` = "OS/390"
31then 31then
32# configure binaries for z/OS 32# configure binaries for z/OS
33 CC=`pwd`"/contrib/xcc" 33 if test -z $CC
34 chmod +x $CC || true 34 then
35 CPP="c89 -E" 35 CC=`pwd`"/contrib/xcc"
36 CXXCPP="c++ -E -+" 36 chmod +x $CC || true
37 fi
38 if test -z $CPP
39 then
40 CPP="c89 -E"
41 fi
42 if test -z $CXXCPP
43 then
44 CXXCPP="c++ -E -+"
45 fi
37# _CCC_CCMODE=1 46# _CCC_CCMODE=1
38# _C89_CCMODE=1 47# _C89_CCMODE=1
39fi 48fi
@@ -134,7 +143,7 @@ AC_CHECK_HEADERS([sys/select.h sys/types.h sys/time.h sys/msg.h netdb.h netinet/
134# libcurl (required for testing) 143# libcurl (required for testing)
135SAVE_LIBS=$LIBS 144SAVE_LIBS=$LIBS
136LIBCURL_CHECK_CONFIG(,,curl=1,curl=0) 145LIBCURL_CHECK_CONFIG(,,curl=1,curl=0)
137AM_CONDITIONAL(HAVE_CURL, test x$curl == x1) 146AM_CONDITIONAL(HAVE_CURL, test x$curl = x1)
138LIBS=$SAVE_LIBS 147LIBS=$SAVE_LIBS
139 148
140# Lib cURL & cURL - OpenSSL versions 149# Lib cURL & cURL - OpenSSL versions
@@ -157,7 +166,7 @@ AC_ARG_ENABLE(messages,
157 [enable_messages=$enableval], 166 [enable_messages=$enableval],
158 [enable_messages="no"]) 167 [enable_messages="no"])
159AC_MSG_RESULT($enable_messages) 168AC_MSG_RESULT($enable_messages)
160if test "$enable_messages" == "yes" 169if test "$enable_messages" = "yes"
161then 170then
162 AC_DEFINE([HAVE_MESSAGES],[1],[Include error messages]) 171 AC_DEFINE([HAVE_MESSAGES],[1],[Include error messages])
163fi 172fi
@@ -224,9 +233,9 @@ AC_ARG_ENABLE([HTTPS],
224 [enable HTTPS support (default is yes)])], 233 [enable HTTPS support (default is yes)])],
225 [enable_HTTPS=$enableval], 234 [enable_HTTPS=$enableval],
226 [enable_HTTPS="yes"]) 235 [enable_HTTPS="yes"])
227if test "$enable_HTTPS" == "yes" 236if test "$enable_HTTPS" = "yes"
228then 237then
229 if test "$gcrypt" == "true" 238 if test "$gcrypt" = "true"
230 then 239 then
231 AC_DEFINE([HTTPS_SUPPORT],[1],[include HTTPS support]) 240 AC_DEFINE([HTTPS_SUPPORT],[1],[include HTTPS support])
232 else 241 else
@@ -238,7 +247,7 @@ else
238fi 247fi
239AC_MSG_RESULT($enable_HTTPS) 248AC_MSG_RESULT($enable_HTTPS)
240 249
241AM_CONDITIONAL(ENABLE_HTTPS, test "$enable_HTTPS" == "yes") 250AM_CONDITIONAL(ENABLE_HTTPS, test "$enable_HTTPS" = "yes")
242 251
243# optional: compile TLS client side code [only for test running] ? 252# optional: compile TLS client side code [only for test running] ?
244AC_MSG_CHECKING(--enable-client-side argument) 253AC_MSG_CHECKING(--enable-client-side argument)
@@ -248,7 +257,7 @@ AC_ARG_ENABLE(client-side,
248 [enable_client_side=$enableval], 257 [enable_client_side=$enableval],
249 [enable_client_side="no"]) 258 [enable_client_side="no"])
250AC_MSG_RESULT($enable_client_side) 259AC_MSG_RESULT($enable_client_side)
251if test "$enable_client_side" == "no" 260if test "$enable_client_side" = "no"
252then 261then
253 AC_DEFINE([MHD_DEBUG_TLS],[0],[Compile client side code. This will enable running some test cases.]) 262 AC_DEFINE([MHD_DEBUG_TLS],[0],[Compile client side code. This will enable running some test cases.])
254 MSG_CLIENT_SIDE="disabled. running some test cases won't be possible" 263 MSG_CLIENT_SIDE="disabled. running some test cases won't be possible"
@@ -357,7 +366,7 @@ AC_MSG_NOTICE([Configuration Summary:
357 HTTPS support: ${enable_HTTPS} 366 HTTPS support: ${enable_HTTPS}
358]) 367])
359 368
360if test "$enable_HTTPS" == "yes" 369if test "$enable_HTTPS" = "yes"
361then 370then
362AC_MSG_NOTICE([HTTPS subsystem configuration: 371AC_MSG_NOTICE([HTTPS subsystem configuration:
363 TLS support: ${enable_TLS} 372 TLS support: ${enable_TLS}