diff options
Diffstat (limited to 'configure.ac')
-rw-r--r-- | configure.ac | 36 |
1 files changed, 36 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac new file mode 100644 index 00000000..39fed6af --- /dev/null +++ b/configure.ac | |||
@@ -0,0 +1,36 @@ | |||
1 | dnl Process this file with autoconf to produce a configure script. | ||
2 | AC_INIT([libwebserver],[0.5.3-GNUnet],[bug-gnunet@gnu.org]) | ||
3 | AM_INIT_AUTOMAKE([libwebserver], [0.5.3-GNUnet]) | ||
4 | AC_CONFIG_HEADER([config.h]) | ||
5 | |||
6 | AC_PROG_CC | ||
7 | AC_PROG_MAKE_SET | ||
8 | AC_PROG_INSTALL | ||
9 | AC_DISABLE_STATIC | ||
10 | AC_PROG_LIBTOOL | ||
11 | |||
12 | AC_HEADER_STDC | ||
13 | AC_CHECK_HEADERS([arpa/inet.h fcntl.h limits.h netinet/in.h stddef.h stdlib.h string.h sys/socket.h sys/time.h unistd.h]) | ||
14 | |||
15 | # Checks for typedefs, structures, and compiler characteristics. | ||
16 | AC_C_CONST | ||
17 | AC_TYPE_SIZE_T | ||
18 | AC_HEADER_TIME | ||
19 | AC_STRUCT_TM | ||
20 | |||
21 | # Checks for library functions. | ||
22 | AC_FUNC_MEMCMP | ||
23 | AC_TYPE_SIGNAL | ||
24 | AC_FUNC_STRFTIME | ||
25 | AC_FUNC_VPRINTF | ||
26 | AC_CHECK_FUNCS([inet_ntoa memset select socket strchr strerror strncasecmp strstr strtol]) | ||
27 | |||
28 | AC_SUBST(INCLUDE) | ||
29 | AC_SUBST(LIBDIR) | ||
30 | AC_SUBST(LIBS) | ||
31 | |||
32 | AC_CONFIG_FILES([Makefile | ||
33 | src/Makefile | ||
34 | include/Makefile | ||
35 | ]) | ||
36 | AC_OUTPUT | ||