aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 5de285d9..f28ba597 100644
--- a/configure.ac
+++ b/configure.ac
@@ -989,7 +989,13 @@ AC_ARG_ENABLE([[heavy-tests]],
989 [a dedicated host with minimal number of background processes and no network] 989 [a dedicated host with minimal number of background processes and no network]
990 [activity is recommended to enable.])], [], 990 [activity is recommended to enable.])], [],
991 [enable_heavy_tests=no]) 991 [enable_heavy_tests=no])
992AS_VAR_IF([enable_heavy_tests], ["yes"], [], [enable_heavy_tests=no]) 992AS_VAR_IF([enable_heavy_tests], ["yes"],
993 [HEAVY_TESTS_NOTPARALLEL='.NOTPARALLEL:'],
994 [
995 enable_heavy_tests=no
996 HEAVY_TESTS_NOTPARALLEL=" "
997 ]
998)
993AM_CONDITIONAL([HEAVY_TESTS],[test "x$enable_heavy_tests" = "xyes"]) 999AM_CONDITIONAL([HEAVY_TESTS],[test "x$enable_heavy_tests" = "xyes"])
994 1000
995AC_ARG_ENABLE([[poll]], 1001AC_ARG_ENABLE([[poll]],
@@ -2529,6 +2535,8 @@ AS_VAR_IF([[enable_asserts]], [["yes"]],
2529 2535
2530MHD_LIB_LDFLAGS="$MHD_LIB_LDFLAGS -export-dynamic -no-undefined" 2536MHD_LIB_LDFLAGS="$MHD_LIB_LDFLAGS -export-dynamic -no-undefined"
2531 2537
2538AC_SUBST([CPU_COUNT])
2539AC_SUBST([HEAVY_TESTS_NOTPARALLEL])
2532AC_SUBST(MHD_LIB_CPPFLAGS) 2540AC_SUBST(MHD_LIB_CPPFLAGS)
2533AC_SUBST(MHD_LIB_CFLAGS) 2541AC_SUBST(MHD_LIB_CFLAGS)
2534AC_SUBST(MHD_LIB_LDFLAGS) 2542AC_SUBST(MHD_LIB_LDFLAGS)