diff options
Diffstat (limited to 'doc/examples/Makefile.am')
-rw-r--r-- | doc/examples/Makefile.am | 76 |
1 files changed, 76 insertions, 0 deletions
diff --git a/doc/examples/Makefile.am b/doc/examples/Makefile.am new file mode 100644 index 00000000..5c1ec7f5 --- /dev/null +++ b/doc/examples/Makefile.am | |||
@@ -0,0 +1,76 @@ | |||
1 | SUBDIRS = . | ||
2 | |||
3 | if USE_PRIVATE_PLIBC_H | ||
4 | PLIBC_INCLUDE = -I$(top_srcdir)/src/include/plibc | ||
5 | endif | ||
6 | |||
7 | AM_CPPFLAGS = \ | ||
8 | $(PLIBC_INCLUDE) \ | ||
9 | -I$(top_srcdir)/src/include \ | ||
10 | @LIBGCRYPT_CFLAGS@ | ||
11 | |||
12 | if USE_COVERAGE | ||
13 | AM_CFLAGS = --coverage | ||
14 | endif | ||
15 | |||
16 | # example programs | ||
17 | noinst_PROGRAMS = \ | ||
18 | basicauthentication \ | ||
19 | hellobrowser \ | ||
20 | logging \ | ||
21 | responseheaders \ | ||
22 | sessions | ||
23 | |||
24 | if ENABLE_HTTPS | ||
25 | noinst_PROGRAMS += \ | ||
26 | tlsauthentication | ||
27 | endif | ||
28 | if HAVE_POSTPROCESSOR | ||
29 | noinst_PROGRAMS += simplepost largepost | ||
30 | endif | ||
31 | |||
32 | if HAVE_W32 | ||
33 | IBERTY=-liberty | ||
34 | endif | ||
35 | |||
36 | basicauthentication_SOURCES = \ | ||
37 | basicauthentication.c | ||
38 | basicauthentication_LDADD = \ | ||
39 | $(top_builddir)/src/daemon/libmicrohttpd.la | ||
40 | |||
41 | hellobrowser_SOURCES = \ | ||
42 | hellobrowser.c | ||
43 | hellobrowser_LDADD = \ | ||
44 | $(top_builddir)/src/daemon/libmicrohttpd.la | ||
45 | |||
46 | logging_SOURCES = \ | ||
47 | logging.c | ||
48 | logging_LDADD = \ | ||
49 | $(top_builddir)/src/daemon/libmicrohttpd.la \ | ||
50 | $(IBERTY) | ||
51 | |||
52 | responseheaders_SOURCES = \ | ||
53 | responseheaders.c | ||
54 | responseheaders_LDADD = \ | ||
55 | $(top_builddir)/src/daemon/libmicrohttpd.la | ||
56 | |||
57 | sessions_SOURCES = \ | ||
58 | sessions.c | ||
59 | sessions_LDADD = \ | ||
60 | $(top_builddir)/src/daemon/libmicrohttpd.la | ||
61 | |||
62 | tlsauthentication_SOURCES = \ | ||
63 | tlsauthentication.c | ||
64 | tlsauthentication_LDADD = \ | ||
65 | $(top_builddir)/src/daemon/libmicrohttpd.la | ||
66 | |||
67 | simplepost_SOURCES = \ | ||
68 | simplepost.c | ||
69 | simplepost_LDADD = \ | ||
70 | $(top_builddir)/src/daemon/libmicrohttpd.la | ||
71 | |||
72 | largepost_SOURCES = \ | ||
73 | largepost.c | ||
74 | largepost_LDADD = \ | ||
75 | $(top_builddir)/src/daemon/libmicrohttpd.la | ||
76 | |||