aboutsummaryrefslogtreecommitdiff
path: root/src/daemon/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/daemon/Makefile.am')
-rw-r--r--src/daemon/Makefile.am49
1 files changed, 23 insertions, 26 deletions
diff --git a/src/daemon/Makefile.am b/src/daemon/Makefile.am
index c52e2610..f3aea3db 100644
--- a/src/daemon/Makefile.am
+++ b/src/daemon/Makefile.am
@@ -1,19 +1,11 @@
1# including '.' mixes up build order when HTTPS is enabled.
2SUBDIRS =
3
4if USE_COVERAGE
5 AM_CFLAGS = -fprofile-arcs -ftest-coverage
6endif
7
8AM_CPPFLAGS = \ 1AM_CPPFLAGS = \
9-I$(top_srcdir)/src/include \ 2 -I$(top_srcdir)/src/include \
10-I$(top_srcdir)/src/daemon \ 3 -I$(top_srcdir)/src/daemon \
11-I$(top_srcdir)/src/daemon/https/lgl \ 4 -I$(top_srcdir)/src/daemon/https/lgl \
12-I$(top_srcdir)/src/daemon/https/x509 \ 5 -I$(top_srcdir)/src/daemon/https/x509 \
13-I$(top_srcdir)/src/daemon/https/minitasn1 \ 6 -I$(top_srcdir)/src/daemon/https/minitasn1 \
14-I$(top_srcdir)/src/daemon/https/tls \ 7 -I$(top_srcdir)/src/daemon/https/tls \
15-I$(top_srcdir)/src/daemon/https \ 8 -I$(top_srcdir)/src/daemon/https
16-I$(GCRYPT_CPPFLAGS)
17 9
18if HAVE_GNU_LD 10if HAVE_GNU_LD
19# If you want to debug with gdb, comment out this line: 11# If you want to debug with gdb, comment out this line:
@@ -26,20 +18,26 @@ lib_LTLIBRARIES = \
26 libmicrohttpd.la 18 libmicrohttpd.la
27 19
28libmicrohttpd_la_SOURCES = \ 20libmicrohttpd_la_SOURCES = \
29connection.c connection.h \ 21 connection.c connection.h \
30reason_phrase.c reason_phrase.h \ 22 reason_phrase.c reason_phrase.h \
31daemon.c \ 23 daemon.c \
32internal.c internal.h \ 24 internal.c internal.h \
33memorypool.c memorypool.h \ 25 memorypool.c memorypool.h \
34postprocessor.c \ 26 postprocessor.c \
35response.c response.h 27 response.c response.h
36libmicrohttpd_la_LDFLAGS = \ 28libmicrohttpd_la_LDFLAGS = \
37 -export-dynamic -version-info 4:3:0 $(retaincommand) 29 -version-info 4:3:0 \
30 -export-dynamic $(retaincommand)
31
32if USE_COVERAGE
33 AM_CFLAGS = --coverage
34endif
38 35
39 36
40if ENABLE_HTTPS 37if ENABLE_HTTPS
41SUBDIRS += https . 38SUBDIRS = https .
42libmicrohttpd_la_SOURCES += connection_https.c connection_https.h 39libmicrohttpd_la_SOURCES += \
40 connection_https.c connection_https.h
43libmicrohttpd_la_LIBADD = \ 41libmicrohttpd_la_LIBADD = \
44 https/lgl/liblgl.la \ 42 https/lgl/liblgl.la \
45 https/x509/libx509.la \ 43 https/x509/libx509.la \
@@ -47,7 +45,6 @@ libmicrohttpd_la_LIBADD = \
47 https/minitasn1/libasn1.la 45 https/minitasn1/libasn1.la
48endif 46endif
49 47
50
51check_PROGRAMS = \ 48check_PROGRAMS = \
52 postprocessor_test \ 49 postprocessor_test \
53 postprocessor_large_test \ 50 postprocessor_large_test \