diff options
Diffstat (limited to 'src/daemon/Makefile.am')
-rw-r--r-- | src/daemon/Makefile.am | 49 |
1 files changed, 23 insertions, 26 deletions
diff --git a/src/daemon/Makefile.am b/src/daemon/Makefile.am index c52e2610..f3aea3db 100644 --- a/src/daemon/Makefile.am +++ b/src/daemon/Makefile.am | |||
@@ -1,19 +1,11 @@ | |||
1 | # including '.' mixes up build order when HTTPS is enabled. | ||
2 | SUBDIRS = | ||
3 | |||
4 | if USE_COVERAGE | ||
5 | AM_CFLAGS = -fprofile-arcs -ftest-coverage | ||
6 | endif | ||
7 | |||
8 | AM_CPPFLAGS = \ | 1 | AM_CPPFLAGS = \ |
9 | -I$(top_srcdir)/src/include \ | 2 | -I$(top_srcdir)/src/include \ |
10 | -I$(top_srcdir)/src/daemon \ | 3 | -I$(top_srcdir)/src/daemon \ |
11 | -I$(top_srcdir)/src/daemon/https/lgl \ | 4 | -I$(top_srcdir)/src/daemon/https/lgl \ |
12 | -I$(top_srcdir)/src/daemon/https/x509 \ | 5 | -I$(top_srcdir)/src/daemon/https/x509 \ |
13 | -I$(top_srcdir)/src/daemon/https/minitasn1 \ | 6 | -I$(top_srcdir)/src/daemon/https/minitasn1 \ |
14 | -I$(top_srcdir)/src/daemon/https/tls \ | 7 | -I$(top_srcdir)/src/daemon/https/tls \ |
15 | -I$(top_srcdir)/src/daemon/https \ | 8 | -I$(top_srcdir)/src/daemon/https |
16 | -I$(GCRYPT_CPPFLAGS) | ||
17 | 9 | ||
18 | if HAVE_GNU_LD | 10 | if HAVE_GNU_LD |
19 | # If you want to debug with gdb, comment out this line: | 11 | # If you want to debug with gdb, comment out this line: |
@@ -26,20 +18,26 @@ lib_LTLIBRARIES = \ | |||
26 | libmicrohttpd.la | 18 | libmicrohttpd.la |
27 | 19 | ||
28 | libmicrohttpd_la_SOURCES = \ | 20 | libmicrohttpd_la_SOURCES = \ |
29 | connection.c connection.h \ | 21 | connection.c connection.h \ |
30 | reason_phrase.c reason_phrase.h \ | 22 | reason_phrase.c reason_phrase.h \ |
31 | daemon.c \ | 23 | daemon.c \ |
32 | internal.c internal.h \ | 24 | internal.c internal.h \ |
33 | memorypool.c memorypool.h \ | 25 | memorypool.c memorypool.h \ |
34 | postprocessor.c \ | 26 | postprocessor.c \ |
35 | response.c response.h | 27 | response.c response.h |
36 | libmicrohttpd_la_LDFLAGS = \ | 28 | libmicrohttpd_la_LDFLAGS = \ |
37 | -export-dynamic -version-info 4:3:0 $(retaincommand) | 29 | -version-info 4:3:0 \ |
30 | -export-dynamic $(retaincommand) | ||
31 | |||
32 | if USE_COVERAGE | ||
33 | AM_CFLAGS = --coverage | ||
34 | endif | ||
38 | 35 | ||
39 | 36 | ||
40 | if ENABLE_HTTPS | 37 | if ENABLE_HTTPS |
41 | SUBDIRS += https . | 38 | SUBDIRS = https . |
42 | libmicrohttpd_la_SOURCES += connection_https.c connection_https.h | 39 | libmicrohttpd_la_SOURCES += \ |
40 | connection_https.c connection_https.h | ||
43 | libmicrohttpd_la_LIBADD = \ | 41 | libmicrohttpd_la_LIBADD = \ |
44 | https/lgl/liblgl.la \ | 42 | https/lgl/liblgl.la \ |
45 | https/x509/libx509.la \ | 43 | https/x509/libx509.la \ |
@@ -47,7 +45,6 @@ libmicrohttpd_la_LIBADD = \ | |||
47 | https/minitasn1/libasn1.la | 45 | https/minitasn1/libasn1.la |
48 | endif | 46 | endif |
49 | 47 | ||
50 | |||
51 | check_PROGRAMS = \ | 48 | check_PROGRAMS = \ |
52 | postprocessor_test \ | 49 | postprocessor_test \ |
53 | postprocessor_large_test \ | 50 | postprocessor_large_test \ |