aboutsummaryrefslogtreecommitdiff
path: root/src/daemon/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/daemon/Makefile.am')
-rw-r--r--src/daemon/Makefile.am130
1 files changed, 2 insertions, 128 deletions
diff --git a/src/daemon/Makefile.am b/src/daemon/Makefile.am
index b2f58c94..b10226fd 100644
--- a/src/daemon/Makefile.am
+++ b/src/daemon/Makefile.am
@@ -23,42 +23,9 @@ libmicrohttpd_la_SOURCES = \
23 postprocessor.c \ 23 postprocessor.c \
24 response.c response.h 24 response.c response.h
25 25
26# example programs
27
28noinst_PROGRAMS = minimal_example fileserver_example
29
30minimal_example_SOURCES = \
31 minimal_example.c
32minimal_example_LDADD = \
33 $(top_builddir)/src/daemon/libmicrohttpd.la
34
35fileserver_example_SOURCES = \
36 fileserver_example.c
37fileserver_example_LDADD = \
38 $(top_builddir)/src/daemon/libmicrohttpd.la
39
40
41# No curl, no testcases
42if HAVE_CURL
43
44check_PROGRAMS = \ 26check_PROGRAMS = \
45 postprocessor_test \ 27 postprocessor_test
46 daemontest \ 28 daemontest
47 daemontest_get \
48 daemontest_post \
49 daemontest_postform \
50 daemontest_post_loop \
51 daemontest_put \
52 daemontest_large_put \
53 daemontest_get11 \
54 daemontest_post11 \
55 daemontest_postform11 \
56 daemontest_post_loop11 \
57 daemontest_put11 \
58 daemontest_large_put11 \
59 daemontest_long_header \
60 daemontest_get_chunked \
61 daemontest_put_chunked
62 29
63TESTS = $(check_PROGRAMS) 30TESTS = $(check_PROGRAMS)
64 31
@@ -71,96 +38,3 @@ postprocessor_test_SOURCES = \
71 postprocessor_test.c 38 postprocessor_test.c
72postprocessor_test_LDADD = \ 39postprocessor_test_LDADD = \
73 $(top_builddir)/src/daemon/libmicrohttpd.la 40 $(top_builddir)/src/daemon/libmicrohttpd.la
74
75daemontest_get_SOURCES = \
76 daemontest_get.c
77daemontest_get_LDADD = \
78 $(top_builddir)/src/daemon/libmicrohttpd.la \
79 @LIBCURL@
80
81daemontest_get_chunked_SOURCES = \
82 daemontest_get_chunked.c
83daemontest_get_chunked_LDADD = \
84 $(top_builddir)/src/daemon/libmicrohttpd.la \
85 @LIBCURL@
86
87daemontest_post_SOURCES = \
88 daemontest_post.c
89daemontest_post_LDADD = \
90 $(top_builddir)/src/daemon/libmicrohttpd.la \
91 @LIBCURL@
92
93daemontest_postform_SOURCES = \
94 daemontest_postform.c
95daemontest_postform_LDADD = \
96 $(top_builddir)/src/daemon/libmicrohttpd.la \
97 @LIBCURL@
98
99daemontest_post_loop_SOURCES = \
100 daemontest_post_loop.c
101daemontest_post_loop_LDADD = \
102 $(top_builddir)/src/daemon/libmicrohttpd.la \
103 @LIBCURL@
104
105daemontest_put_SOURCES = \
106 daemontest_put.c
107daemontest_put_LDADD = \
108 $(top_builddir)/src/daemon/libmicrohttpd.la \
109 @LIBCURL@
110
111daemontest_put_chunked_SOURCES = \
112 daemontest_put_chunked.c
113daemontest_put_chunked_LDADD = \
114 $(top_builddir)/src/daemon/libmicrohttpd.la \
115 @LIBCURL@
116
117daemontest_get11_SOURCES = \
118 daemontest_get.c
119daemontest_get11_LDADD = \
120 $(top_builddir)/src/daemon/libmicrohttpd.la \
121 @LIBCURL@
122
123daemontest_post11_SOURCES = \
124 daemontest_post.c
125daemontest_post11_LDADD = \
126 $(top_builddir)/src/daemon/libmicrohttpd.la \
127 @LIBCURL@
128
129daemontest_postform11_SOURCES = \
130 daemontest_postform.c
131daemontest_postform11_LDADD = \
132 $(top_builddir)/src/daemon/libmicrohttpd.la \
133 @LIBCURL@
134
135daemontest_post_loop11_SOURCES = \
136 daemontest_post_loop.c
137daemontest_post_loop11_LDADD = \
138 $(top_builddir)/src/daemon/libmicrohttpd.la \
139 @LIBCURL@
140
141daemontest_put11_SOURCES = \
142 daemontest_put.c
143daemontest_put11_LDADD = \
144 $(top_builddir)/src/daemon/libmicrohttpd.la \
145 @LIBCURL@
146
147
148daemontest_large_put_SOURCES = \
149 daemontest_large_put.c
150daemontest_large_put_LDADD = \
151 $(top_builddir)/src/daemon/libmicrohttpd.la \
152 @LIBCURL@
153
154daemontest_large_put11_SOURCES = \
155 daemontest_large_put.c
156daemontest_large_put11_LDADD = \
157 $(top_builddir)/src/daemon/libmicrohttpd.la \
158 @LIBCURL@
159
160daemontest_long_header_SOURCES = \
161 daemontest_long_header.c
162daemontest_long_header_LDADD = \
163 $(top_builddir)/src/daemon/libmicrohttpd.la \
164 @LIBCURL@
165
166endif