aboutsummaryrefslogtreecommitdiff
path: root/src/daemon/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/daemon/Makefile.am')
-rw-r--r--src/daemon/Makefile.am13
1 files changed, 10 insertions, 3 deletions
diff --git a/src/daemon/Makefile.am b/src/daemon/Makefile.am
index 4902dc52..30ec59f1 100644
--- a/src/daemon/Makefile.am
+++ b/src/daemon/Makefile.am
@@ -12,7 +12,7 @@ lib_LTLIBRARIES = \
12 libmicrohttpd.la 12 libmicrohttpd.la
13 13
14libmicrohttpd_la_LDFLAGS = \ 14libmicrohttpd_la_LDFLAGS = \
15 -export-dynamic -version-info 2:1:1 $(retaincommand) 15 -export-dynamic -version-info 3:0:0 $(retaincommand)
16libmicrohttpd_la_SOURCES = \ 16libmicrohttpd_la_SOURCES = \
17 connection.c connection.h \ 17 connection.c connection.h \
18 reason_phrase.c reason_phrase.h \ 18 reason_phrase.c reason_phrase.h \
@@ -48,7 +48,6 @@ check_PROGRAMS = \
48 daemontest_postform \ 48 daemontest_postform \
49 daemontest_post_loop \ 49 daemontest_post_loop \
50 daemontest_put \ 50 daemontest_put \
51 daemontest_put_chunked \
52 daemontest_large_put \ 51 daemontest_large_put \
53 daemontest_get11 \ 52 daemontest_get11 \
54 daemontest_post11 \ 53 daemontest_post11 \
@@ -56,7 +55,9 @@ check_PROGRAMS = \
56 daemontest_post_loop11 \ 55 daemontest_post_loop11 \
57 daemontest_put11 \ 56 daemontest_put11 \
58 daemontest_large_put11 \ 57 daemontest_large_put11 \
59 daemontest_long_header 58 daemontest_long_header \
59 daemontest_get_chunked \
60 daemontest_put_chunked
60 61
61TESTS = $(check_PROGRAMS) 62TESTS = $(check_PROGRAMS)
62 63
@@ -71,6 +72,12 @@ daemontest_get_LDADD = \
71 $(top_builddir)/src/daemon/libmicrohttpd.la \ 72 $(top_builddir)/src/daemon/libmicrohttpd.la \
72 @LIBCURL@ 73 @LIBCURL@
73 74
75daemontest_get_chunked_SOURCES = \
76 daemontest_get_chunked.c
77daemontest_get_chunked_LDADD = \
78 $(top_builddir)/src/daemon/libmicrohttpd.la \
79 @LIBCURL@
80
74daemontest_post_SOURCES = \ 81daemontest_post_SOURCES = \
75 daemontest_post.c 82 daemontest_post.c
76daemontest_post_LDADD = \ 83daemontest_post_LDADD = \