aboutsummaryrefslogtreecommitdiff
path: root/src/daemon/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/daemon/Makefile.am')
-rw-r--r--src/daemon/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/src/daemon/Makefile.am b/src/daemon/Makefile.am
index 7a4696fc..c9b73287 100644
--- a/src/daemon/Makefile.am
+++ b/src/daemon/Makefile.am
@@ -2,11 +2,17 @@ SUBDIRS = .
2 2
3INCLUDES = -I$(top_srcdir)/src/include 3INCLUDES = -I$(top_srcdir)/src/include
4 4
5if HAVE_GNU_LD
6 retaincommand=-Wl,--retain-symbols-file -Wl,SYMBOLS
7endif
8
9EXTRA_DIST = SYMBOLS
10
5lib_LTLIBRARIES = \ 11lib_LTLIBRARIES = \
6 libmicrohttpd.la 12 libmicrohttpd.la
7 13
8libmicrohttpd_la_LDFLAGS = \ 14libmicrohttpd_la_LDFLAGS = \
9 -export-dynamic -version-info 2:0:0 15 -export-dynamic -version-info 2:0:0 $(retaincommand)
10libmicrohttpd_la_SOURCES = \ 16libmicrohttpd_la_SOURCES = \
11 connection.c connection.h \ 17 connection.c connection.h \
12 daemon.c \ 18 daemon.c \