aboutsummaryrefslogtreecommitdiff
path: root/src/examples/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/examples/Makefile.am')
-rw-r--r--src/examples/Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/src/examples/Makefile.am b/src/examples/Makefile.am
index 5dcee4d2..1f0a65af 100644
--- a/src/examples/Makefile.am
+++ b/src/examples/Makefile.am
@@ -67,7 +67,8 @@ endif
67if HAVE_POSIX_THREADS 67if HAVE_POSIX_THREADS
68if ENABLE_UPGRADE 68if ENABLE_UPGRADE
69noinst_PROGRAMS += \ 69noinst_PROGRAMS += \
70 upgrade_example 70 upgrade_example \
71 websocket_threaded_example
71endif 72endif
72endif 73endif
73 74
@@ -104,6 +105,14 @@ upgrade_example_LDADD = \
104 $(top_builddir)/src/microhttpd/libmicrohttpd.la \ 105 $(top_builddir)/src/microhttpd/libmicrohttpd.la \
105 $(PTHREAD_LIBS) 106 $(PTHREAD_LIBS)
106 107
108websocket_threaded_example_SOURCES = \
109 websocket_threaded_example.c
110websocket_threaded_example_CFLAGS = \
111 $(PTHREAD_CFLAGS) $(AM_CFLAGS)
112websocket_threaded_example_LDADD = \
113 $(top_builddir)/src/microhttpd/libmicrohttpd.la \
114 $(PTHREAD_LIBS)
115
107timeout_SOURCES = \ 116timeout_SOURCES = \
108 timeout.c 117 timeout.c
109timeout_LDADD = \ 118timeout_LDADD = \