aboutsummaryrefslogtreecommitdiff
path: root/src/microhttpd/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/microhttpd/Makefile.am')
-rw-r--r--src/microhttpd/Makefile.am13
1 files changed, 7 insertions, 6 deletions
diff --git a/src/microhttpd/Makefile.am b/src/microhttpd/Makefile.am
index 4ff623ae..54706f56 100644
--- a/src/microhttpd/Makefile.am
+++ b/src/microhttpd/Makefile.am
@@ -6,7 +6,7 @@ AM_CPPFLAGS = \
6 $(PLIBC_INCLUDE) \ 6 $(PLIBC_INCLUDE) \
7 -I$(top_srcdir)/src/include \ 7 -I$(top_srcdir)/src/include \
8 -I$(top_srcdir)/src/daemon \ 8 -I$(top_srcdir)/src/daemon \
9 @LIBGCRYPT_CFLAGS@ 9 @LIBGCRYPT_CFLAGS@
10 10
11EXTRA_DIST = EXPORT.sym 11EXTRA_DIST = EXPORT.sym
12 12
@@ -23,6 +23,7 @@ libmicrohttpd_la_SOURCES = \
23 response.c response.h 23 response.c response.h
24libmicrohttpd_la_LDFLAGS = \ 24libmicrohttpd_la_LDFLAGS = \
25 $(MHD_LIB_LDFLAGS) \ 25 $(MHD_LIB_LDFLAGS) \
26 -export-symbols $(top_srcdir)/src/microhttpd/EXPORT.sym \
26 -version-info @LIB_VERSION_CURRENT@:@LIB_VERSION_REVISION@:@LIB_VERSION_AGE@ 27 -version-info @LIB_VERSION_CURRENT@:@LIB_VERSION_REVISION@:@LIB_VERSION_AGE@
27 28
28if USE_COVERAGE 29if USE_COVERAGE
@@ -60,7 +61,7 @@ endif
60 61
61 62
62check_PROGRAMS = \ 63check_PROGRAMS = \
63 test_daemon 64 test_daemon
64 65
65if HAVE_POSTPROCESSOR 66if HAVE_POSTPROCESSOR
66check_PROGRAMS += \ 67check_PROGRAMS += \
@@ -74,19 +75,19 @@ TESTS = $(check_PROGRAMS)
74test_daemon_SOURCES = \ 75test_daemon_SOURCES = \
75 test_daemon.c 76 test_daemon.c
76test_daemon_LDADD = \ 77test_daemon_LDADD = \
77 $(top_builddir)/src/microhttpd/libmicrohttpd.la 78 $(top_builddir)/src/microhttpd/libmicrohttpd.la
78 79
79test_postprocessor_SOURCES = \ 80test_postprocessor_SOURCES = \
80 test_postprocessor.c 81 test_postprocessor.c
81test_postprocessor_LDADD = \ 82test_postprocessor_LDADD = \
82 $(top_builddir)/src/microhttpd/libmicrohttpd.la 83 $(top_builddir)/src/microhttpd/libmicrohttpd.la
83 84
84test_postprocessor_amp_SOURCES = \ 85test_postprocessor_amp_SOURCES = \
85 test_postprocessor_amp.c 86 test_postprocessor_amp.c
86test_postprocessor_amp_LDADD = \ 87test_postprocessor_amp_LDADD = \
87 $(top_builddir)/src/microhttpd/libmicrohttpd.la 88 $(top_builddir)/src/microhttpd/libmicrohttpd.la
88 89
89test_postprocessor_large_SOURCES = \ 90test_postprocessor_large_SOURCES = \
90 test_postprocessor_large.c 91 test_postprocessor_large.c
91test_postprocessor_large_LDADD = \ 92test_postprocessor_large_LDADD = \
92 $(top_builddir)/src/microhttpd/libmicrohttpd.la 93 $(top_builddir)/src/microhttpd/libmicrohttpd.la