summaryrefslogtreecommitdiff
path: root/src/microhttpd/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/microhttpd/Makefile.am')
-rw-r--r--src/microhttpd/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/microhttpd/Makefile.am b/src/microhttpd/Makefile.am
index 9a32f598..b60ff81e 100644
--- a/src/microhttpd/Makefile.am
+++ b/src/microhttpd/Makefile.am
@@ -146,6 +146,10 @@ check_PROGRAMS = \
test_daemon \
test_upgrade
+if ENABLE_HTTPS
+ check_PROGRAMS += test_upgrade_ssl
+endif
+
if HAVE_POSTPROCESSOR
check_PROGRAMS += \
test_postprocessor \
@@ -171,6 +175,11 @@ test_upgrade_SOURCES = \
test_upgrade_LDADD = \
$(top_builddir)/src/microhttpd/libmicrohttpd.la
+test_upgrade_ssl_SOURCES = \
+ test_upgrade_ssl.c
+test_upgrade_ssl_LDADD = \
+ $(top_builddir)/src/microhttpd/libmicrohttpd.la
+
test_postprocessor_SOURCES = \
test_postprocessor.c
test_postprocessor_CPPFLAGS = \