aboutsummaryrefslogtreecommitdiff
path: root/src/microhttpd/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/microhttpd/Makefile.am')
-rw-r--r--src/microhttpd/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/microhttpd/Makefile.am b/src/microhttpd/Makefile.am
index 9a32f598..b60ff81e 100644
--- a/src/microhttpd/Makefile.am
+++ b/src/microhttpd/Makefile.am
@@ -146,6 +146,10 @@ check_PROGRAMS = \
146 test_daemon \ 146 test_daemon \
147 test_upgrade 147 test_upgrade
148 148
149if ENABLE_HTTPS
150 check_PROGRAMS += test_upgrade_ssl
151endif
152
149if HAVE_POSTPROCESSOR 153if HAVE_POSTPROCESSOR
150check_PROGRAMS += \ 154check_PROGRAMS += \
151 test_postprocessor \ 155 test_postprocessor \
@@ -171,6 +175,11 @@ test_upgrade_SOURCES = \
171test_upgrade_LDADD = \ 175test_upgrade_LDADD = \
172 $(top_builddir)/src/microhttpd/libmicrohttpd.la 176 $(top_builddir)/src/microhttpd/libmicrohttpd.la
173 177
178test_upgrade_ssl_SOURCES = \
179 test_upgrade_ssl.c
180test_upgrade_ssl_LDADD = \
181 $(top_builddir)/src/microhttpd/libmicrohttpd.la
182
174test_postprocessor_SOURCES = \ 183test_postprocessor_SOURCES = \
175 test_postprocessor.c 184 test_postprocessor.c
176test_postprocessor_CPPFLAGS = \ 185test_postprocessor_CPPFLAGS = \