aboutsummaryrefslogtreecommitdiff
path: root/src/microhttpd/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/microhttpd/Makefile.am')
-rw-r--r--src/microhttpd/Makefile.am19
1 files changed, 6 insertions, 13 deletions
diff --git a/src/microhttpd/Makefile.am b/src/microhttpd/Makefile.am
index c72e183f..1e555c18 100644
--- a/src/microhttpd/Makefile.am
+++ b/src/microhttpd/Makefile.am
@@ -5,10 +5,6 @@ AM_CPPFLAGS = \
5 5
6AM_CFLAGS = $(HIDDEN_VISIBILITY_CFLAGS) 6AM_CFLAGS = $(HIDDEN_VISIBILITY_CFLAGS)
7 7
8if HAVE_W32
9MHD_W32_LIB = $(top_builddir)/src/platform/libplatform_interface.la
10endif
11
12lib_LTLIBRARIES = \ 8lib_LTLIBRARIES = \
13 libmicrohttpd.la 9 libmicrohttpd.la
14 10
@@ -71,6 +67,7 @@ libmicrohttpd_la_SOURCES = \
71 mhd_locks.h \ 67 mhd_locks.h \
72 mhd_sockets.c mhd_sockets.h \ 68 mhd_sockets.c mhd_sockets.h \
73 mhd_itc.c mhd_itc.h \ 69 mhd_itc.c mhd_itc.h \
70 mhd_compat.c mhd_compat.h \
74 response.c response.h 71 response.c response.h
75libmicrohttpd_la_CPPFLAGS = \ 72libmicrohttpd_la_CPPFLAGS = \
76 $(AM_CPPFLAGS) $(MHD_LIB_CPPFLAGS) \ 73 $(AM_CPPFLAGS) $(MHD_LIB_CPPFLAGS) \
@@ -82,9 +79,7 @@ libmicrohttpd_la_LDFLAGS = \
82 $(W32_MHD_LIB_LDFLAGS) \ 79 $(W32_MHD_LIB_LDFLAGS) \
83 -version-info @LIB_VERSION_CURRENT@:@LIB_VERSION_REVISION@:@LIB_VERSION_AGE@ 80 -version-info @LIB_VERSION_CURRENT@:@LIB_VERSION_REVISION@:@LIB_VERSION_AGE@
84libmicrohttpd_la_LIBADD = \ 81libmicrohttpd_la_LIBADD = \
85 $(MHD_W32_LIB) $(MHD_LIBDEPS) 82 $(MHD_LIBDEPS)
86libmicrohttpd_la_DEPENDENCIES = \
87 $(MHD_W32_LIB)
88 83
89if HAVE_W32 84if HAVE_W32
90MHD_DLL_RES_SRC = microhttpd_dll_res.rc 85MHD_DLL_RES_SRC = microhttpd_dll_res.rc
@@ -172,12 +167,11 @@ test_daemon_LDADD = \
172 $(top_builddir)/src/microhttpd/libmicrohttpd.la 167 $(top_builddir)/src/microhttpd/libmicrohttpd.la
173 168
174test_postprocessor_SOURCES = \ 169test_postprocessor_SOURCES = \
175 test_postprocessor.c 170 test_postprocessor.c mhd_compat.c
176test_postprocessor_CPPFLAGS = \ 171test_postprocessor_CPPFLAGS = \
177 $(AM_CPPFLAGS) $(GNUTLS_CPPFLAGS) 172 $(AM_CPPFLAGS) $(GNUTLS_CPPFLAGS)
178test_postprocessor_LDADD = \ 173test_postprocessor_LDADD = \
179 $(top_builddir)/src/microhttpd/libmicrohttpd.la \ 174 $(top_builddir)/src/microhttpd/libmicrohttpd.la
180 $(MHD_W32_LIB)
181 175
182test_postprocessor_amp_SOURCES = \ 176test_postprocessor_amp_SOURCES = \
183 test_postprocessor_amp.c 177 test_postprocessor_amp.c
@@ -187,12 +181,11 @@ test_postprocessor_amp_LDADD = \
187 $(top_builddir)/src/microhttpd/libmicrohttpd.la 181 $(top_builddir)/src/microhttpd/libmicrohttpd.la
188 182
189test_postprocessor_large_SOURCES = \ 183test_postprocessor_large_SOURCES = \
190 test_postprocessor_large.c 184 test_postprocessor_large.c mhd_compat.c
191test_postprocessor_large_CPPFLAGS = \ 185test_postprocessor_large_CPPFLAGS = \
192 $(AM_CPPFLAGS) $(GNUTLS_CPPFLAGS) 186 $(AM_CPPFLAGS) $(GNUTLS_CPPFLAGS)
193test_postprocessor_large_LDADD = \ 187test_postprocessor_large_LDADD = \
194 $(top_builddir)/src/microhttpd/libmicrohttpd.la \ 188 $(top_builddir)/src/microhttpd/libmicrohttpd.la
195 $(MHD_W32_LIB)
196 189
197test_shutdown_select_SOURCES = \ 190test_shutdown_select_SOURCES = \
198 test_shutdown_select.c 191 test_shutdown_select.c