aboutsummaryrefslogtreecommitdiff
path: root/src/microhttpd/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/microhttpd/Makefile.am')
-rw-r--r--src/microhttpd/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/src/microhttpd/Makefile.am b/src/microhttpd/Makefile.am
index fbc545eb..b400d8e6 100644
--- a/src/microhttpd/Makefile.am
+++ b/src/microhttpd/Makefile.am
@@ -171,6 +171,10 @@ libmicrohttpd_la_SOURCES += \
171 mhd_bithelpers.h mhd_byteorder.h mhd_align.h \ 171 mhd_bithelpers.h mhd_byteorder.h mhd_align.h \
172 md5.c md5.h \ 172 md5.c md5.h \
173 sha256.c sha256.h 173 sha256.c sha256.h
174if ENABLE_SHA512_256
175libmicrohttpd_la_SOURCES += \
176 sha512_256.c sha512_256.h
177endif
174endif 178endif
175 179
176if ENABLE_BAUTH 180if ENABLE_BAUTH
@@ -215,6 +219,11 @@ check_PROGRAMS = \
215 test_options \ 219 test_options \
216 test_set_panic 220 test_set_panic
217 221
222if ENABLE_SHA512_256
223check_PROGRAMS += \
224 test_sha512_256
225endif
226
218if HAVE_POSIX_THREADS 227if HAVE_POSIX_THREADS
219if ENABLE_UPGRADE 228if ENABLE_UPGRADE
220if USE_POSIX_THREADS 229if USE_POSIX_THREADS
@@ -448,6 +457,10 @@ test_sha256_SOURCES = \
448 test_sha256.c test_helpers.h \ 457 test_sha256.c test_helpers.h \
449 sha256.c sha256.h mhd_bithelpers.h mhd_byteorder.h mhd_align.h 458 sha256.c sha256.h mhd_bithelpers.h mhd_byteorder.h mhd_align.h
450 459
460test_sha512_256_SOURCES = \
461 test_sha512_256.c test_helpers.h \
462 sha512_256.c sha512_256.h mhd_bithelpers.h mhd_byteorder.h mhd_align.h
463
451test_sha1_SOURCES = \ 464test_sha1_SOURCES = \
452 test_sha1.c test_helpers.h \ 465 test_sha1.c test_helpers.h \
453 sha1.c sha1.h mhd_bithelpers.h mhd_byteorder.h mhd_align.h 466 sha1.c sha1.h mhd_bithelpers.h mhd_byteorder.h mhd_align.h