aboutsummaryrefslogtreecommitdiff
path: root/src/microhttpd/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/microhttpd/Makefile.am')
-rw-r--r--src/microhttpd/Makefile.am20
1 files changed, 16 insertions, 4 deletions
diff --git a/src/microhttpd/Makefile.am b/src/microhttpd/Makefile.am
index b400d8e6..10a32f59 100644
--- a/src/microhttpd/Makefile.am
+++ b/src/microhttpd/Makefile.am
@@ -168,9 +168,15 @@ endif
168if ENABLE_DAUTH 168if ENABLE_DAUTH
169libmicrohttpd_la_SOURCES += \ 169libmicrohttpd_la_SOURCES += \
170 digestauth.c digestauth.h \ 170 digestauth.c digestauth.h \
171 mhd_bithelpers.h mhd_byteorder.h mhd_align.h \ 171 mhd_bithelpers.h mhd_byteorder.h mhd_align.h
172 md5.c md5.h \ 172if ENABLE_MD5
173libmicrohttpd_la_SOURCES += \
174 md5.c md5.h
175endif
176if ENABLE_SHA256
177libmicrohttpd_la_SOURCES += \
173 sha256.c sha256.h 178 sha256.c sha256.h
179endif
174if ENABLE_SHA512_256 180if ENABLE_SHA512_256
175libmicrohttpd_la_SOURCES += \ 181libmicrohttpd_la_SOURCES += \
176 sha512_256.c sha512_256.h 182 sha512_256.c sha512_256.h
@@ -197,9 +203,7 @@ check_PROGRAMS = \
197 test_str_pct \ 203 test_str_pct \
198 test_str_bin_hex \ 204 test_str_bin_hex \
199 test_http_reasons \ 205 test_http_reasons \
200 test_md5 \
201 test_sha1 \ 206 test_sha1 \
202 test_sha256 \
203 test_start_stop \ 207 test_start_stop \
204 test_daemon \ 208 test_daemon \
205 test_response_entries \ 209 test_response_entries \
@@ -219,6 +223,14 @@ check_PROGRAMS = \
219 test_options \ 223 test_options \
220 test_set_panic 224 test_set_panic
221 225
226if ENABLE_MD5
227check_PROGRAMS += \
228 test_md5
229endif
230if ENABLE_SHA256
231check_PROGRAMS += \
232 test_sha256
233endif
222if ENABLE_SHA512_256 234if ENABLE_SHA512_256
223check_PROGRAMS += \ 235check_PROGRAMS += \
224 test_sha512_256 236 test_sha512_256