summaryrefslogtreecommitdiff
path: root/src/microhttpd/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/microhttpd/Makefile.am')
-rw-r--r--src/microhttpd/Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/src/microhttpd/Makefile.am b/src/microhttpd/Makefile.am
index 58284d17..67ec3cd8 100644
--- a/src/microhttpd/Makefile.am
+++ b/src/microhttpd/Makefile.am
@@ -141,6 +141,7 @@ endif
check_PROGRAMS = \
test_shutdown_select \
+ test_shutdown_poll \
test_daemon
if HAVE_POSTPROCESSOR
@@ -154,7 +155,8 @@ TESTS = $(check_PROGRAMS)
if !HAVE_LISTEN_SHUTDOWN
XFAIL_TESTS = \
- test_shutdown_select
+ test_shutdown_select \
+ test_shutdown_poll
endif
test_daemon_SOURCES = \
@@ -193,3 +195,12 @@ test_shutdown_select_CFLAGS = \
test_shutdown_select_LDADD = \
$(PTHREAD_LIBS)
endif
+
+test_shutdown_poll_SOURCES = \
+ test_shutdown_select.c
+if USE_POSIX_THREADS
+test_shutdown_poll_CFLAGS = \
+ test_shutdown_select_CFLAGS
+test_shutdown_poll_LDADD = \
+ test_shutdown_select_LDADD
+endif