aboutsummaryrefslogtreecommitdiff
path: root/src/microhttpd/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/microhttpd/Makefile.am')
-rw-r--r--src/microhttpd/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/microhttpd/Makefile.am b/src/microhttpd/Makefile.am
index 0f2672de..d89f3c19 100644
--- a/src/microhttpd/Makefile.am
+++ b/src/microhttpd/Makefile.am
@@ -166,6 +166,10 @@ endif
166 166
167TESTS = $(check_PROGRAMS) 167TESTS = $(check_PROGRAMS)
168 168
169# Do not test trigger of select by shutdown of listen socket
170# on Cygwin as this ability is deliberately ignored on Cygwin
171# to improve compatibility with core OS.
172if !CYGWIN_TARGET
169if HAVE_LISTEN_SHUTDOWN 173if HAVE_LISTEN_SHUTDOWN
170check_PROGRAMS += \ 174check_PROGRAMS += \
171 test_shutdown_select \ 175 test_shutdown_select \
@@ -175,6 +179,7 @@ check_PROGRAMS += \
175 test_shutdown_select_ignore \ 179 test_shutdown_select_ignore \
176 test_shutdown_poll_ignore 180 test_shutdown_poll_ignore
177endif 181endif
182endif
178 183
179test_start_stop_SOURCES = \ 184test_start_stop_SOURCES = \
180 test_start_stop.c 185 test_start_stop.c