aboutsummaryrefslogtreecommitdiff
path: root/src/microhttpd/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/microhttpd/Makefile.am')
-rw-r--r--src/microhttpd/Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/src/microhttpd/Makefile.am b/src/microhttpd/Makefile.am
index 2c59876a..22b6100d 100644
--- a/src/microhttpd/Makefile.am
+++ b/src/microhttpd/Makefile.am
@@ -133,7 +133,8 @@ endif
133if ENABLE_DAUTH 133if ENABLE_DAUTH
134libmicrohttpd_la_SOURCES += \ 134libmicrohttpd_la_SOURCES += \
135 digestauth.c \ 135 digestauth.c \
136 md5.c md5.h 136 md5.c md5.h \
137 sha256.c sha256.h
137endif 138endif
138 139
139if ENABLE_BAUTH 140if ENABLE_BAUTH
@@ -160,18 +161,18 @@ check_PROGRAMS = \
160 161
161if HAVE_POSIX_THREADS 162if HAVE_POSIX_THREADS
162if ENABLE_UPGRADE 163if ENABLE_UPGRADE
163if USE_POSIX_THREADS 164if USE_POSIX_THREADS
164 check_PROGRAMS += test_upgrade 165 check_PROGRAMS += test_upgrade
165endif 166endif
166if USE_W32_THREADS 167if USE_W32_THREADS
167 check_PROGRAMS += test_upgrade 168 check_PROGRAMS += test_upgrade
168endif 169endif
169if ENABLE_HTTPS 170if ENABLE_HTTPS
170if USE_POSIX_THREADS 171if USE_POSIX_THREADS
171check_PROGRAMS += test_upgrade_tls 172check_PROGRAMS += test_upgrade_tls
172endif 173endif
173if USE_W32_THREADS 174if USE_W32_THREADS
174check_PROGRAMS += test_upgrade_tls 175check_PROGRAMS += test_upgrade_tls
175endif 176endif
176endif 177endif
177endif 178endif