summaryrefslogtreecommitdiff
path: root/src/microhttpd/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/microhttpd/Makefile.am')
-rw-r--r--src/microhttpd/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/microhttpd/Makefile.am b/src/microhttpd/Makefile.am
index 58d39c43..b7ad13d9 100644
--- a/src/microhttpd/Makefile.am
+++ b/src/microhttpd/Makefile.am
@@ -153,6 +153,12 @@ endif
TESTS = $(check_PROGRAMS)
+if !HAVE_LISTEN_SHUTDOWN
+XFAIL_TESTS = \
+ test_shutdown_select \
+ test_shutdown_poll
+endif
+
test_daemon_SOURCES = \
test_daemon.c
test_daemon_LDADD = \