aboutsummaryrefslogtreecommitdiff
path: root/src/testcurl/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/testcurl/Makefile.am')
-rw-r--r--src/testcurl/Makefile.am29
1 files changed, 20 insertions, 9 deletions
diff --git a/src/testcurl/Makefile.am b/src/testcurl/Makefile.am
index 3bf81e7d..e46bbb2d 100644
--- a/src/testcurl/Makefile.am
+++ b/src/testcurl/Makefile.am
@@ -71,14 +71,6 @@ THREAD_ONLY_TESTS += \
71endif 71endif
72endif 72endif
73 73
74if ENABLE_DAUTH
75THREAD_ONLY_TESTS += \
76 test_digestauth \
77 test_digestauth_sha256 \
78 test_digestauth_with_arguments \
79 test_digestauth_concurrent
80endif
81
82if HEAVY_TESTS 74if HEAVY_TESTS
83if HAVE_POSIX_THREADS 75if HAVE_POSIX_THREADS
84THREAD_ONLY_TESTS += \ 76THREAD_ONLY_TESTS += \
@@ -158,7 +150,7 @@ check_PROGRAMS += \
158endif 150endif
159 151
160if HAVE_POSTPROCESSOR 152if HAVE_POSTPROCESSOR
161 check_PROGRAMS += \ 153check_PROGRAMS += \
162 test_post \ 154 test_post \
163 test_postform \ 155 test_postform \
164 test_post_loop \ 156 test_post_loop \
@@ -167,6 +159,19 @@ if HAVE_POSTPROCESSOR
167 test_post_loop11 159 test_post_loop11
168endif 160endif
169 161
162
163if ENABLE_DAUTH
164THREAD_ONLY_TESTS += \
165 test_digestauth \
166 test_digestauth_sha256 \
167 test_digestauth_with_arguments \
168 test_digestauth_concurrent
169
170check_PROGRAMS += \
171 test_digestauth_emu_ext \
172 test_digestauth_emu_ext_oldapi
173endif
174
170if HEAVY_TESTS 175if HEAVY_TESTS
171if HAVE_FORK_WAITPID 176if HAVE_FORK_WAITPID
172if HAVE_CURL_BINARY 177if HAVE_CURL_BINARY
@@ -268,6 +273,12 @@ test_digestauth_concurrent_CFLAGS = \
268test_digestauth_concurrent_LDADD = \ 273test_digestauth_concurrent_LDADD = \
269 @LIBGCRYPT_LIBS@ $(LDADD) $(PTHREAD_LIBS) $(LDADD) 274 @LIBGCRYPT_LIBS@ $(LDADD) $(PTHREAD_LIBS) $(LDADD)
270 275
276test_digestauth_emu_ext_SOURCES = \
277 test_digestauth_emu_ext.c
278
279test_digestauth_emu_ext_oldapi_SOURCES = \
280 test_digestauth_emu_ext.c
281
271test_get_iovec_SOURCES = \ 282test_get_iovec_SOURCES = \
272 test_get_iovec.c mhd_has_in_name.h 283 test_get_iovec.c mhd_has_in_name.h
273 284