diff options
Diffstat (limited to 'src/testcurl/Makefile.am')
-rw-r--r-- | src/testcurl/Makefile.am | 29 |
1 files changed, 20 insertions, 9 deletions
diff --git a/src/testcurl/Makefile.am b/src/testcurl/Makefile.am index 3bf81e7d..e46bbb2d 100644 --- a/src/testcurl/Makefile.am +++ b/src/testcurl/Makefile.am | |||
@@ -71,14 +71,6 @@ THREAD_ONLY_TESTS += \ | |||
71 | endif | 71 | endif |
72 | endif | 72 | endif |
73 | 73 | ||
74 | if ENABLE_DAUTH | ||
75 | THREAD_ONLY_TESTS += \ | ||
76 | test_digestauth \ | ||
77 | test_digestauth_sha256 \ | ||
78 | test_digestauth_with_arguments \ | ||
79 | test_digestauth_concurrent | ||
80 | endif | ||
81 | |||
82 | if HEAVY_TESTS | 74 | if HEAVY_TESTS |
83 | if HAVE_POSIX_THREADS | 75 | if HAVE_POSIX_THREADS |
84 | THREAD_ONLY_TESTS += \ | 76 | THREAD_ONLY_TESTS += \ |
@@ -158,7 +150,7 @@ check_PROGRAMS += \ | |||
158 | endif | 150 | endif |
159 | 151 | ||
160 | if HAVE_POSTPROCESSOR | 152 | if HAVE_POSTPROCESSOR |
161 | check_PROGRAMS += \ | 153 | check_PROGRAMS += \ |
162 | test_post \ | 154 | test_post \ |
163 | test_postform \ | 155 | test_postform \ |
164 | test_post_loop \ | 156 | test_post_loop \ |
@@ -167,6 +159,19 @@ if HAVE_POSTPROCESSOR | |||
167 | test_post_loop11 | 159 | test_post_loop11 |
168 | endif | 160 | endif |
169 | 161 | ||
162 | |||
163 | if ENABLE_DAUTH | ||
164 | THREAD_ONLY_TESTS += \ | ||
165 | test_digestauth \ | ||
166 | test_digestauth_sha256 \ | ||
167 | test_digestauth_with_arguments \ | ||
168 | test_digestauth_concurrent | ||
169 | |||
170 | check_PROGRAMS += \ | ||
171 | test_digestauth_emu_ext \ | ||
172 | test_digestauth_emu_ext_oldapi | ||
173 | endif | ||
174 | |||
170 | if HEAVY_TESTS | 175 | if HEAVY_TESTS |
171 | if HAVE_FORK_WAITPID | 176 | if HAVE_FORK_WAITPID |
172 | if HAVE_CURL_BINARY | 177 | if HAVE_CURL_BINARY |
@@ -268,6 +273,12 @@ test_digestauth_concurrent_CFLAGS = \ | |||
268 | test_digestauth_concurrent_LDADD = \ | 273 | test_digestauth_concurrent_LDADD = \ |
269 | @LIBGCRYPT_LIBS@ $(LDADD) $(PTHREAD_LIBS) $(LDADD) | 274 | @LIBGCRYPT_LIBS@ $(LDADD) $(PTHREAD_LIBS) $(LDADD) |
270 | 275 | ||
276 | test_digestauth_emu_ext_SOURCES = \ | ||
277 | test_digestauth_emu_ext.c | ||
278 | |||
279 | test_digestauth_emu_ext_oldapi_SOURCES = \ | ||
280 | test_digestauth_emu_ext.c | ||
281 | |||
271 | test_get_iovec_SOURCES = \ | 282 | test_get_iovec_SOURCES = \ |
272 | test_get_iovec.c mhd_has_in_name.h | 283 | test_get_iovec.c mhd_has_in_name.h |
273 | 284 | ||