aboutsummaryrefslogtreecommitdiff
path: root/src/testcurl/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/testcurl/Makefile.am')
-rw-r--r--src/testcurl/Makefile.am22
1 files changed, 21 insertions, 1 deletions
diff --git a/src/testcurl/Makefile.am b/src/testcurl/Makefile.am
index e46bbb2d..749e31e2 100644
--- a/src/testcurl/Makefile.am
+++ b/src/testcurl/Makefile.am
@@ -169,7 +169,12 @@ THREAD_ONLY_TESTS += \
169 169
170check_PROGRAMS += \ 170check_PROGRAMS += \
171 test_digestauth_emu_ext \ 171 test_digestauth_emu_ext \
172 test_digestauth_emu_ext_oldapi 172 test_digestauth_emu_ext_oldapi \
173 test_digestauth2 \
174 test_digestauth2_oldapi \
175 test_digestauth2_userhash \
176 test_digestauth2_sha256 \
177 test_digestauth2_sha256_userhash
173endif 178endif
174 179
175if HEAVY_TESTS 180if HEAVY_TESTS
@@ -279,6 +284,21 @@ test_digestauth_emu_ext_SOURCES = \
279test_digestauth_emu_ext_oldapi_SOURCES = \ 284test_digestauth_emu_ext_oldapi_SOURCES = \
280 test_digestauth_emu_ext.c 285 test_digestauth_emu_ext.c
281 286
287test_digestauth2_SOURCES = \
288 test_digestauth2.c mhd_has_param.h mhd_has_in_name.h
289
290test_digestauth2_oldapi_SOURCES = \
291 test_digestauth2.c mhd_has_param.h mhd_has_in_name.h
292
293test_digestauth2_userhash_SOURCES = \
294 test_digestauth2.c mhd_has_param.h mhd_has_in_name.h
295
296test_digestauth2_sha256_SOURCES = \
297 test_digestauth2.c mhd_has_param.h mhd_has_in_name.h
298
299test_digestauth2_sha256_userhash_SOURCES = \
300 test_digestauth2.c mhd_has_param.h mhd_has_in_name.h
301
282test_get_iovec_SOURCES = \ 302test_get_iovec_SOURCES = \
283 test_get_iovec.c mhd_has_in_name.h 303 test_get_iovec.c mhd_has_in_name.h
284 304