aboutsummaryrefslogtreecommitdiff
path: root/src/testcurl/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/testcurl/Makefile.am')
-rw-r--r--src/testcurl/Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/src/testcurl/Makefile.am b/src/testcurl/Makefile.am
index 7ec4ff68..33e95d36 100644
--- a/src/testcurl/Makefile.am
+++ b/src/testcurl/Makefile.am
@@ -137,7 +137,12 @@ test_digestauth_with_arguments_LDADD = \
137 @LIBCURL@ @LIBGCRYPT_LIBS@ 137 @LIBCURL@ @LIBGCRYPT_LIBS@
138 138
139test_get_sendfile_SOURCES = \ 139test_get_sendfile_SOURCES = \
140 test_get_sendfile.c 140 test_get_sendfile.c \
141 ../platform/platform_interface.h
142if HAVE_W32
143test_get_sendfile_SOURCES += \
144 ../platform/w32functions.h ../platform/w32functions.c
145endif
141test_get_sendfile_LDADD = \ 146test_get_sendfile_LDADD = \
142 $(top_builddir)/src/microhttpd/libmicrohttpd.la \ 147 $(top_builddir)/src/microhttpd/libmicrohttpd.la \
143 @LIBCURL@ 148 @LIBCURL@
@@ -215,6 +220,10 @@ test_get11_LDADD = \
215 220
216test_get_sendfile11_SOURCES = \ 221test_get_sendfile11_SOURCES = \
217 test_get_sendfile.c 222 test_get_sendfile.c
223if HAVE_W32
224test_get_sendfile11_SOURCES += \
225 ../platform/w32functions.h ../platform/w32functions.c
226endif
218test_get_sendfile11_LDADD = \ 227test_get_sendfile11_LDADD = \
219 $(top_builddir)/src/microhttpd/libmicrohttpd.la \ 228 $(top_builddir)/src/microhttpd/libmicrohttpd.la \
220 @LIBCURL@ 229 @LIBCURL@