aboutsummaryrefslogtreecommitdiff
path: root/src/testcurl/https/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/testcurl/https/Makefile.am')
-rw-r--r--src/testcurl/https/Makefile.am43
1 files changed, 24 insertions, 19 deletions
diff --git a/src/testcurl/https/Makefile.am b/src/testcurl/https/Makefile.am
index 239ce2ca..7454ab06 100644
--- a/src/testcurl/https/Makefile.am
+++ b/src/testcurl/https/Makefile.am
@@ -10,8 +10,9 @@ if HAVE_GNUTLS_SNI
10endif 10endif
11 11
12if HAVE_POSIX_THREADS 12if HAVE_POSIX_THREADS
13 HTTPS_PARALLEL_TESTS = test_https_get_parallel \ 13 HTTPS_PARALLEL_TESTS = \
14 test_https_get_parallel_threads 14 test_https_get_parallel \
15 test_https_get_parallel_threads
15endif 16endif
16 17
17CPU_COUNT_DEF = -DCPU_COUNT=$(CPU_COUNT) 18CPU_COUNT_DEF = -DCPU_COUNT=$(CPU_COUNT)
@@ -22,32 +23,36 @@ AM_CPPFLAGS = \
22 -I$(top_srcdir)/src/platform \ 23 -I$(top_srcdir)/src/platform \
23 $(LIBCURL_CPPFLAGS) $(MHD_TLS_LIB_CPPFLAGS) 24 $(LIBCURL_CPPFLAGS) $(MHD_TLS_LIB_CPPFLAGS)
24 25
25check_PROGRAMS = \ 26THREAD_ONLY_TESTS = \
26 test_tls_options \ 27 test_tls_options \
27 test_tls_authentication \ 28 test_tls_authentication \
28 test_https_multi_daemon \
29 test_https_get \
30 $(TEST_HTTPS_SNI) \
31 test_https_get_select \
32 $(HTTPS_PARALLEL_TESTS) \ 29 $(HTTPS_PARALLEL_TESTS) \
30 $(TEST_HTTPS_SNI) \
33 test_https_session_info \ 31 test_https_session_info \
34 test_https_time_out \ 32 test_https_time_out \
33 test_https_multi_daemon \
34 test_https_get \
35 test_empty_response 35 test_empty_response
36 36
37EXTRA_DIST = cert.pem key.pem \ 37check_PROGRAMS = \
38 host1.crt host1.key host2.crt host2.key 38 test_https_get_select
39
40if USE_POSIX_THREADS
41check_PROGRAMS +=
42 $(THREAD_ONLY_TESTS)
43endif
44if USE_W32_THREADS
45check_PROGRAMS +=
46 $(THREAD_ONLY_TESTS)
47endif
48
49EXTRA_DIST = \
50 cert.pem key.pem \
51 host1.crt host1.key \
52 host2.crt host2.key
39 53
40TESTS = \ 54TESTS = \
41 test_tls_options \ 55 $(check_PROGRAMS)
42 test_https_multi_daemon \
43 test_https_get \
44 $(TEST_HTTPS_SNI) \
45 test_https_get_select \
46 $(HTTPS_PARALLEL_TESTS) \
47 test_https_session_info \
48 test_https_time_out \
49 test_tls_authentication \
50 test_empty_response
51 56
52 57
53test_https_time_out_SOURCES = \ 58test_https_time_out_SOURCES = \