aboutsummaryrefslogtreecommitdiff
path: root/src/testzzuf/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/testzzuf/Makefile.am')
-rw-r--r--src/testzzuf/Makefile.am16
1 files changed, 14 insertions, 2 deletions
diff --git a/src/testzzuf/Makefile.am b/src/testzzuf/Makefile.am
index 329fe04d..be31bad2 100644
--- a/src/testzzuf/Makefile.am
+++ b/src/testzzuf/Makefile.am
@@ -11,6 +11,9 @@ AM_CPPFLAGS = -I$(top_srcdir)/src/include \
11 11
12EXTRA_DIST = README socat.c 12EXTRA_DIST = README socat.c
13 13
14THREAD_ONLY_TESTS = \
15 test_long_header
16
14check_PROGRAMS = \ 17check_PROGRAMS = \
15 test_get \ 18 test_get \
16 test_get_chunked \ 19 test_get_chunked \
@@ -23,8 +26,17 @@ check_PROGRAMS = \
23 test_post11 \ 26 test_post11 \
24 test_post_form11 \ 27 test_post_form11 \
25 test_put11 \ 28 test_put11 \
26 test_put_large11 \ 29 test_put_large11
27 test_long_header 30
31if USE_POSIX_THREADS
32check_PROGRAMS +=
33 $(THREAD_ONLY_TESTS)
34endif
35if USE_W32_THREADS
36check_PROGRAMS +=
37 $(THREAD_ONLY_TESTS)
38endif
39
28 40
29TESTS = $(check_PROGRAMS) 41TESTS = $(check_PROGRAMS)
30 42