aboutsummaryrefslogtreecommitdiff
path: root/src/testzzuf/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/testzzuf/Makefile.am')
-rw-r--r--src/testzzuf/Makefile.am125
1 files changed, 125 insertions, 0 deletions
diff --git a/src/testzzuf/Makefile.am b/src/testzzuf/Makefile.am
new file mode 100644
index 00000000..b48b75be
--- /dev/null
+++ b/src/testzzuf/Makefile.am
@@ -0,0 +1,125 @@
1SUBDIRS = .
2
3INCLUDES = -I$(top_srcdir)/src/include
4
5check_PROGRAMS = \
6 postprocessor_test \
7 daemontest \
8 daemontest_get \
9 daemontest_post \
10 daemontest_postform \
11 daemontest_post_loop \
12 daemontest_put \
13 daemontest_large_put \
14 daemontest_get11 \
15 daemontest_post11 \
16 daemontest_postform11 \
17 daemontest_post_loop11 \
18 daemontest_put11 \
19 daemontest_large_put11 \
20 daemontest_long_header \
21 daemontest_get_chunked \
22 daemontest_put_chunked
23
24TESTS = $(check_PROGRAMS)
25
26daemontest_SOURCES = \
27 daemontest.c
28daemontest_LDADD = \
29 $(top_builddir)/src/daemon/libmicrohttpd.la
30
31postprocessor_test_SOURCES = \
32 postprocessor_test.c
33postprocessor_test_LDADD = \
34 $(top_builddir)/src/daemon/libmicrohttpd.la
35
36daemontest_get_SOURCES = \
37 daemontest_get.c
38daemontest_get_LDADD = \
39 $(top_builddir)/src/daemon/libmicrohttpd.la \
40 @LIBCURL@
41
42daemontest_get_chunked_SOURCES = \
43 daemontest_get_chunked.c
44daemontest_get_chunked_LDADD = \
45 $(top_builddir)/src/daemon/libmicrohttpd.la \
46 @LIBCURL@
47
48daemontest_post_SOURCES = \
49 daemontest_post.c
50daemontest_post_LDADD = \
51 $(top_builddir)/src/daemon/libmicrohttpd.la \
52 @LIBCURL@
53
54daemontest_postform_SOURCES = \
55 daemontest_postform.c
56daemontest_postform_LDADD = \
57 $(top_builddir)/src/daemon/libmicrohttpd.la \
58 @LIBCURL@
59
60daemontest_post_loop_SOURCES = \
61 daemontest_post_loop.c
62daemontest_post_loop_LDADD = \
63 $(top_builddir)/src/daemon/libmicrohttpd.la \
64 @LIBCURL@
65
66daemontest_put_SOURCES = \
67 daemontest_put.c
68daemontest_put_LDADD = \
69 $(top_builddir)/src/daemon/libmicrohttpd.la \
70 @LIBCURL@
71
72daemontest_put_chunked_SOURCES = \
73 daemontest_put_chunked.c
74daemontest_put_chunked_LDADD = \
75 $(top_builddir)/src/daemon/libmicrohttpd.la \
76 @LIBCURL@
77
78daemontest_get11_SOURCES = \
79 daemontest_get.c
80daemontest_get11_LDADD = \
81 $(top_builddir)/src/daemon/libmicrohttpd.la \
82 @LIBCURL@
83
84daemontest_post11_SOURCES = \
85 daemontest_post.c
86daemontest_post11_LDADD = \
87 $(top_builddir)/src/daemon/libmicrohttpd.la \
88 @LIBCURL@
89
90daemontest_postform11_SOURCES = \
91 daemontest_postform.c
92daemontest_postform11_LDADD = \
93 $(top_builddir)/src/daemon/libmicrohttpd.la \
94 @LIBCURL@
95
96daemontest_post_loop11_SOURCES = \
97 daemontest_post_loop.c
98daemontest_post_loop11_LDADD = \
99 $(top_builddir)/src/daemon/libmicrohttpd.la \
100 @LIBCURL@
101
102daemontest_put11_SOURCES = \
103 daemontest_put.c
104daemontest_put11_LDADD = \
105 $(top_builddir)/src/daemon/libmicrohttpd.la \
106 @LIBCURL@
107
108
109daemontest_large_put_SOURCES = \
110 daemontest_large_put.c
111daemontest_large_put_LDADD = \
112 $(top_builddir)/src/daemon/libmicrohttpd.la \
113 @LIBCURL@
114
115daemontest_large_put11_SOURCES = \
116 daemontest_large_put.c
117daemontest_large_put11_LDADD = \
118 $(top_builddir)/src/daemon/libmicrohttpd.la \
119 @LIBCURL@
120
121daemontest_long_header_SOURCES = \
122 daemontest_long_header.c
123daemontest_long_header_LDADD = \
124 $(top_builddir)/src/daemon/libmicrohttpd.la \
125 @LIBCURL@