aboutsummaryrefslogtreecommitdiff
path: root/src/testzzuf/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/testzzuf/Makefile.am')
-rw-r--r--src/testzzuf/Makefile.am56
1 files changed, 13 insertions, 43 deletions
diff --git a/src/testzzuf/Makefile.am b/src/testzzuf/Makefile.am
index c657f34e..db85c679 100644
--- a/src/testzzuf/Makefile.am
+++ b/src/testzzuf/Makefile.am
@@ -1,13 +1,22 @@
1# This Makefile.am is in the public domain 1# This Makefile.am is in the public domain
2SUBDIRS = . 2SUBDIRS = .
3 3
4AM_CPPFLAGS = \
5 -I$(top_srcdir)/src/include \
6 -DMHD_CPU_COUNT=$(CPU_COUNT) \
7 $(LIBCURL_CPPFLAGS)
8
9AM_CFLAGS = $(CFLAGS_ac) @LIBGCRYPT_CFLAGS@
10
11AM_LDFLAGS = $(LDFLAGS_ac)
12
4if USE_COVERAGE 13if USE_COVERAGE
5 AM_CFLAGS = -fprofile-arcs -ftest-coverage 14 AM_CFLAGS += -fprofile-arcs -ftest-coverage
6endif 15endif
7 16
8 17LDADD = \
9AM_CPPFLAGS = -I$(top_srcdir)/src/include \ 18 $(top_builddir)/src/microhttpd/libmicrohttpd.la \
10 $(LIBCURL_CPPFLAGS) 19 @LIBCURL@
11 20
12EXTRA_DIST = README socat.c 21EXTRA_DIST = README socat.c
13 22
@@ -45,80 +54,41 @@ TESTS = $(check_PROGRAMS)
45 54
46test_get_SOURCES = \ 55test_get_SOURCES = \
47 test_get.c 56 test_get.c
48test_get_LDADD = \
49 $(top_builddir)/src/microhttpd/libmicrohttpd.la \
50 @LIBCURL@
51 57
52test_get_chunked_SOURCES = \ 58test_get_chunked_SOURCES = \
53 test_get_chunked.c 59 test_get_chunked.c
54test_get_chunked_LDADD = \
55 $(top_builddir)/src/microhttpd/libmicrohttpd.la \
56 @LIBCURL@
57 60
58test_post_SOURCES = \ 61test_post_SOURCES = \
59 test_post.c 62 test_post.c
60test_post_LDADD = \
61 $(top_builddir)/src/microhttpd/libmicrohttpd.la \
62 @LIBCURL@
63 63
64test_post_form_SOURCES = \ 64test_post_form_SOURCES = \
65 test_post_form.c 65 test_post_form.c
66test_post_form_LDADD = \
67 $(top_builddir)/src/microhttpd/libmicrohttpd.la \
68 @LIBCURL@
69 66
70test_put_SOURCES = \ 67test_put_SOURCES = \
71 test_put.c 68 test_put.c
72test_put_LDADD = \
73 $(top_builddir)/src/microhttpd/libmicrohttpd.la \
74 @LIBCURL@
75 69
76test_put_chunked_SOURCES = \ 70test_put_chunked_SOURCES = \
77 test_put_chunked.c 71 test_put_chunked.c
78test_put_chunked_LDADD = \
79 $(top_builddir)/src/microhttpd/libmicrohttpd.la \
80 @LIBCURL@
81 72
82test_put_large_SOURCES = \ 73test_put_large_SOURCES = \
83 test_put_large.c 74 test_put_large.c
84test_put_large_LDADD = \
85 $(top_builddir)/src/microhttpd/libmicrohttpd.la \
86 @LIBCURL@
87 75
88 76
89 77
90test_get11_SOURCES = \ 78test_get11_SOURCES = \
91 test_get.c 79 test_get.c
92test_get11_LDADD = \
93 $(top_builddir)/src/microhttpd/libmicrohttpd.la \
94 @LIBCURL@
95 80
96test_post11_SOURCES = \ 81test_post11_SOURCES = \
97 test_post.c 82 test_post.c
98test_post11_LDADD = \
99 $(top_builddir)/src/microhttpd/libmicrohttpd.la \
100 @LIBCURL@
101 83
102test_post_form11_SOURCES = \ 84test_post_form11_SOURCES = \
103 test_post_form.c 85 test_post_form.c
104test_post_form11_LDADD = \
105 $(top_builddir)/src/microhttpd/libmicrohttpd.la \
106 @LIBCURL@
107 86
108test_put11_SOURCES = \ 87test_put11_SOURCES = \
109 test_put.c 88 test_put.c
110test_put11_LDADD = \
111 $(top_builddir)/src/microhttpd/libmicrohttpd.la \
112 @LIBCURL@
113 89
114test_put_large11_SOURCES = \ 90test_put_large11_SOURCES = \
115 test_put_large.c 91 test_put_large.c
116test_put_large11_LDADD = \
117 $(top_builddir)/src/microhttpd/libmicrohttpd.la \
118 @LIBCURL@
119 92
120test_long_header_SOURCES = \ 93test_long_header_SOURCES = \
121 test_long_header.c 94 test_long_header.c
122test_long_header_LDADD = \
123 $(top_builddir)/src/microhttpd/libmicrohttpd.la \
124 @LIBCURL@